Offline mode no longer works after latest update

Technical Support
I have been playing StarCraft II in offline mode for nearly a year now. I get the authentication needed dialog at regular intervals as expected. Now I can no longer get it to work in offline mode at all. I can connect to Battlenet and launch the game and even play through multiple levels, but as soon as I disconnect from the internet and launch the game it repeatedly tells me that authentication is needed and it will not work.
I had been having trouble with my satellite service not sending or receiving emails, but Hughesnet did something that fixed that issue. After what ever they did when I launched the game while connected it immediately started updating to the latest version of the game as well as updating the Blizzard app. I have been buying and playing many Blizzard games for many years, but this new authentication every 30 days BS has become totally annoying to the point that I will probably never buy or use another one of your products...

VERY FRUSTRATED CUSTOMER !!!
OK... Update... I completely uninstalled the game and the Blizzard app and reinstalled it. I took my computer to a friends house with 100 MB cable internet service. I launched the game played a full campaign mission and saved the game.
when I disconnected from his internet and tried to play offline mode again it says I need to authenticate. I re-connect to the internet and launch the game and it works. I deleted the Blizzard Entertainment cache folder from c:\progamData and ran the game while online with no problem. Again I disconnected from the internet and tried offline mode again and it says I need to authenticate AGAIN!!!!!!!@!!!!

Who do I see about getting my money back for this total BS crap of a game that I cannot play because I live out of town where my only option is satellite internet service.
Same issue here - I cannot go online at all at home; I should only need to log in every 30 days from somewhere else, but nothing I have tried will allow me to play the game off line.
1 sec ago

I bought the disk, and I have an account. When I go through the steps, and disable the internet connection and it gives the option to play offline, when I click it it says "Connect to authorize your game client. You also need at least one Starcraft11 character on the account with purchased content.......I don't know what this means or what to do???...Can you help please?
07/22/2017 03:31 PMPosted by JFOZZ
1 sec ago

I bought the disk, and I have an account. When I go through the steps, and disable the internet connection and it gives the option to play offline, when I click it it says "Connect to authorize your game client. You also need at least one Starcraft11 character on the account with purchased content.......I don't know what this means or what to do???...Can you help please?
I just spent the last half hour filling in all the blanks and creating the requested files, then typing out a detailed description of all of the steps that I have tried to remedy the problem to make a support "web ticket" only to get a page not found error when I clicked submit. I don't know if it was submitted or not , but this is really starting to piss me off !!!!!!!!!!!!!!!
Does anyone from Blizzard even read these posts? Or is this not very high on the priority list?
I do not get any response at all????....Is there a number to call????
Authentication is failing to save for offline mode... So offline will not work without being connected to the net first. After starting a game I can disconnect and continue to play and I just click OK when the "connection lost" window pops up.
LAULDRA 16:47:00
i was digging
LAULDRA 16:47:07
and did find a confirmed bug with authentication
LAULDRA 16:47:31
Checking progress
LAULDRA 16:47:57
It was confirmed on the 25th of last month and we haven't yet found a fix but they do have a team assigned to it
Need help on this too. So sad with paying customers with slow internet service
same problem, I'm about to go on a trip with little to no internet connection and just try to put it to offline mode to no avail.
Yeah i have the same authorization issue as well. When i couldn't connect to battle.net because of maintenance the other week I wanted to play the campaign. I ended up getting the authorization notification and was unable to access anything.
Same problem any solution?
Howdy!

Sorry about not catching this thread sooner, I thought I got Rogg updated to this issue but it was another thread. Offline mode after the recent patch ran into an authentication error causing it not to work correctly. Our developers are looking to get this issue resolved as quickly as possible but it will most likely require a patch. We are working as fast as we can to address offline mode and Editor authentication issues.

Thank you!
Same problem.
Can u please hurry it up with the patch I'm going crazy here thank u : ')
I just got Starcraft2 about a week ago. Is this common with Blizzard games? I saw that this complaint has gone back to 2014 and will most likely get a refund.
No it's not common, I've never had this problem until recent.

08/11/2017 02:01 PMPosted by Dinochopchop
I just got Starcraft2 about a week ago. Is this common with Blizzard games? I saw that this complaint has gone back to 2014 and will most likely get a refund.
CE1F7D0A-51C7-4B1B-908E-BFCAEBB63817

I have the latest updates, I get all the way loading maps. And the game just crashes. I try playing offline but it doesn't work. I'm starting to think I wasted money buy this game. Ive been playing StarCraft for almost 20 years. I've literally bought Brood War 10 times for a stupid CD Key. With these Blizzard games... its always something......Frustrating...

Join the Conversation

Return to Forum