Can't play replays in LOTV

Bug Report

I'm trying to play the replay from this link: but whenever I try to load it the game crashes and I get the error report "Can't download game data from Blizzard's servers...etc". It looks like this game was played in July 2016. I am able to play newer replays from that site with no problem. I've tried using 32-bit client (Windows) and Scan + Repair tool. Any other thoughts on how I might be able to watch this replay?
Spread the word of this bug:
Keep the word of the replay bug around the bug report!
Still an issue
Where are you guys?
i got this when i tried to watch my replay

Hello Metajovian,

Currently, there is an issue with replays older than version 3.11.0, not playing properly in the SC2 game client. The development teams are aware of this issue, and are working to make sure the fix is so players can run the old replays from a majority of the “3.XX.X” version SC2 builds; such as the 3.3.2 version replay you downloaded. That being said, It may take some time for a fix to be released, I apologize for the inconvenience.


Do you have an ETA on a fix for this?

Thank you.
I've getting some problems with replays from korea, all recent matchs, same error. Tried rename the files because of the incognito names (\\\\\\\\\\\) but not working either.
Is this getting fixed today?
Welp it's still not fixed, guess I'll still be waiting another month ._.
Why won't you listen to me QA?
Sad face

Join the Conversation

Return to Forum