Green Selection Box Non-Existent

Technical Support
1 2 3 5 Next
Hi Blizzard.
I just loaded up sc2 and patched it. I qued up for a ladder game. Once in game, I noticed that my green selection box is gone. What I mean by this is that when I select a unit, I cannot see that it is selected with the exception of looking all the way down at the bottom of the screen. Normally I would see my unit highlighted by a green circle or box directly underneath the unit(s) selected. This green box/circle is gone now. There is no option to toggle this on or off in the options menu and this is the first time I have ever encountered anything like this. There is also another user on the TLNet forums experiencing the same issue. I cannot play the game like this at all as it makes things confusing. Please help

Cordially,

Robert
So another user with the same issue went testing in game. When I lift up my CC, the selected unit/building circle/box shows up. It goes away when I land it. Flying units have the selected unit circle/box. That's it. Everything was working fine pre-patch. I also went in game and confirmed this.
I am having the same issue. Selection boxes are gone since the last patch. Please look into this.
Is there somewhere that I can complain about the quality of support that we receive here? Just about every other online multiplayer gaming producing company that has games that receive patches has infinitely better support. I literally get answers/solutions within 4 hours or less. Why is it blizzard has virtually no standard when it comes to this? I looked at a ton of posts on this forum and lots go completely unanswered by support representatives for up to 3 months! 3 months! That's absurd. Blizzard, Where are your standards? This company used to lead the market and set standards, What happened?
I have the same issue after downloading the patch. I just did a re-install and no change. I cannot play the game like this. It is completely unenjoyable now.
Same issue here. It is weird that the green circle appear partly when the unit is on a ramp (see my screen shot). I tried reinstall and delete the My Documents/Starcraft II folder but didnt work
https://flic.kr/p/HiDLCT
Me too... Help pls.
Me too. Supposed to have a tournament tomorrow...

To explain:

Normally when you select a unit, it shows in 3 places:
-the Minimap (green highlight)
-the "Command Card" (bottom of the screen with portrait and wire model)
-on screen, surrounded by a green circle.

this last one is missing with the recent glitch.
Have the same problem Blizzard. Please fix it asap!
This is driving me crazy!!!

The game is not enjoyable with this glitch. Can someone from Blizzard at least acknowledge that this is an issue?
Hey all,

Thank you for the reports. We are aware of the green selection circle not showing for some players and are investigating the cause of this. This does look related to the flickering issues we are seeing with AMD crossfire enabled. While we do work on finding a fix for this we do have some workaround you can all try that we have seen help some player.

• Change StarCraft II to fullscreen mode in the StarCraft II graphic settings.

• Reset In-Game Options.
    1) Select the game in the Blizzard app and click Options .
    2) Click Game Settings.
    3) Click on Reset In-Game Options.
    4) Click Done and launch the game normally.


• To be on the safe side make sure Windows and the drivers in the computer are up to date.

• Please lower the graphic setting in Starcraft II to see if there is a difference.

• Disable AMD Crossfire
Please fix this!!!
I'm have the same problem here too, i just posted about it. I didn't see this post first. Still need help.
I followed the instructions and the issue persist.
I can see the green circles in 2vs2 , 3vs3 and another modes. But not in 1vs1 or 1vs1 vs AI.
Sometimes (in 1vs1) I can see part of the green circle in buildings, the part that I cant see, seem buried under ground. In fact, the green circle appears if the building start to fly. And I see perfectly the yellow circles when I select mineral fields.
The same here...i wont play like this
same, pls fix that :(
same problem persists. blizzard what did you guys do with patch 4.0/4.1 to where now all the sudden your game isn't working properly? We didn't change anything on our end. This issue with your game was non-existent until you patched it. This is so annoying. Fix it asap.
I swear if a problem like this happened in League of Legends Riot would have addressed it within a few hours and given the amount of time that has passed, they would have fixed it already. Blizzard, you have managed to become a mediocre game company. You managed to release an incomplete/mediocre quality game in form of SCR, barely support it, neglect to properly manage it and pull the same !@#$ with sc2 when it comes to properly managing your game. Get it together. My confidence in this company used to be through the roof. I used to buy any game specifically based on the principle that blizzard made it because they put good games out. Now I won't even do that because I know once blizzard get's my money they aren't gonna deliver. Get it together or you will go out of business eventually because this is a capitalist country and more companies are stealing your customers simple because they offer a better service or game/deal with issues with urgency or in a more timely manner.
So, what about problem solving?

Join the Conversation

Return to Forum