Graphics device not available at this time error (and my fix)

Technical Support
Hey guys,

New windows update broke my SC2. Seems all other Blizz games work. Tried updating drivers on video card, repairing game and reinstalling. None worked. Ultimately I had to go back to the prior version of windows and that fixed it (based on old posts with similar problem which points to issues with the windows creators club updates). Will this happen again?

I am running an EVGA GTX 950 btw
Thanks for the post Iscander. I would recommend before rolling back for users to try some troubleshooting. Not all users are experiencing issues with the latest Windows 10 Fall Creators Update. If we can troubleshoot while keeping the OS updated that would be ideal.

I'd recommend to try the following workarounds:
- Right click on the desktop -> Display size -> Change Resolution to a lower option. Once completed retest the game. If this works you can exit the game and change your desktop resolution back before retesting again.
- AMD users could try turning on GPU scaling: http://support.amd.com/en-us/kb-articles/Pages/UnableToSetGPUScaling.aspx
- Check for and disable any third party Overlays and streaming programs for testing.
- Goto Documents -> StarCraft II folder -> Delete the Variables.txt file to reset the game's settings.
- You may also try seeing if the game runs in 32bit mode. If it runs retest 64bit afterwards.

Thank you!
11/19/2017 12:14 PMPosted by Zuvykree
Thanks for the post Iscander. I would recommend before rolling back for users to try some troubleshooting. Not all users are experiencing issues with the latest Windows 10 Fall Creators Update. If we can troubleshoot while keeping the OS updated that would be ideal.

I'd recommend to try the following workarounds:
- Right click on the desktop -> Display size -> Change Resolution to a lower option. Once completed retest the game. If this works you can exit the game and change your desktop resolution back before retesting again.
- AMD users could try turning on GPU scaling: http://support.amd.com/en-us/kb-articles/Pages/UnableToSetGPUScaling.aspx
- Check for and disable any third party [url="https://us.battle.net/support/en/article/31366"]Overlays [/url]and streaming programs for testing.
- Goto Documents -> StarCraft II folder -> Delete the Variables.txt file to reset the game's settings.
- You may also try seeing if the game runs in [url="https://us.battle.net/support/en/article/33881"]32bit [/url]mode. If it runs retest 64bit afterwards.

Thank you!


Wish I had seen this before. Do you recommend I re update windows? I dont want to break the game again. Seemed to only affect SC2 BTW. Overwatch, HOTS all worked fine.
If you don't mind I think these steps should help us narrow the issue down.
11/19/2017 12:43 PMPosted by Zuvykree
If you don't mind I think these steps should help us narrow the issue down.


Hi,

So I updated back to the latest windows and had the same problem. Deleting Variables.txt fixed it. Hope this helps others and helps you narrowing down what the issue is
Ok, when I turn my resolution back up to 2715 either in game or via the NVIDIA geforce experience to up my graphics I get the same problem. Please advice.
Hey all. Just wanted to say that I had the same issue as Iscander and it was also resolved by deleting the variables.txt file. I don't have the game resolution issue however. Thanks for getting this nailed down!
Hi guys,

The variables.txt file deletion didn't help but when I set my resolution to a lower "Recommended" value in Windows 10 x64 then my game started normally just fine. (Note: This wasn't "Recommended" by Windows till its last update finalized.)
The game itself runs in HD or 1920 x 1080 on a 42" monitor. It is beautiful and all at extreme highest settings. Going back to the desktop and changing Windows 10 back to HD wrecks it again. SO, set Windows 10 to a LOW graphics setting, StarCraft II works fine and then re-set Windows. A little frustrating.
I did update all my AMD drivers, and re-wrote the Registry files as well. These 2 ideas didn't work for my Hardware either.
I am running a basic Intel i7 quad core, 16 GB RAM with an AMD R9 270 graphics card. On BTW, other Blizzard games work fine. Therefore a Starcraft II / Windows 10 patch required? Wait to see.
I am running again and THANKS to all for their posts and happy gaming.
i have no variables.txt
11/19/2017 12:14 PMPosted by Zuvykree
Thanks for the post Iscander. I would recommend before rolling back for users to try some troubleshooting. Not all users are experiencing issues with the latest Windows 10 Fall Creators Update. If we can troubleshoot while keeping the OS updated that would be ideal.

I'd recommend to try the following workarounds:
- Right click on the desktop -> Display size -> Change Resolution to a lower option. Once completed retest the game. If this works you can exit the game and change your desktop resolution back before retesting again.
- AMD users could try turning on GPU scaling: http://support.amd.com/en-us/kb-articles/Pages/UnableToSetGPUScaling.aspx
- Check for and disable any third party [url="https://us.battle.net/support/en/article/31366"]Overlays [/url]and streaming programs for testing.
- Goto Documents -> StarCraft II folder -> Delete the Variables.txt file to reset the game's settings.
- You may also try seeing if the game runs in [url="https://us.battle.net/support/en/article/33881"]32bit [/url]mode. If it runs retest 64bit afterwards.

Thank you!
I had the same issue today with the graphics card error message. I was able to fix it by resetting my SC 2 settings. I took the advice from an earlier post. Hope it works for you.

Thanks
Deleting the variables.txt file helped me, thanks for the help.
I had same problem after updating Nvida drivers. Deleting the Variables.txt file allowed the game to open.
i have never had the problem nor the variables.txt. guess owning it is the reason you had a problem to begin with.
Deleting variables.txt fixed it for me

It's on your Documents\Starcraft II folder
I can also confirm that deleting variables.txt can fix this issue.
I tried everything in the recommendations above I do not have a Variables.txt file to delete as the game is a fresh install and has never launched. I lowered my resolution to 600x800... no change. I ran it in 32 bit version. no luck... I have turned discord completely off and still no luck.. At this point I have a game that I can't play.
Installed the game and having the same problem. No Variables.txt file to tinker with. Would appreciate some advise or assistance in how to troubleshoot this.
ive tried all of these and it still doesnt work plz help
Fresh Install - No variables.txt to delete
No overlays or third party apps installed...freshly wiped PC.
Updated Drivers - NVIDIA GeForce GTX680
Disabled Windows Game Bar
Lowered resolution to native 720p 1280x720
Set to launch in 32-bit mode

None of these fixes worked. PLEASE help.

Join the Conversation

Return to Forum