AMD Crossfire + SC2 issues since latest patch

Technical Support
I have AMD Crossfire and since the latest patch I haven't been able to use it without insane flicker and stutter. Never had a problem with AMD Crossfire until this, Whats going on? I have a R9 280 and a HD7950 in Crossfire (Same cards basically)

(Forced to run it at single GPU)
Same here with my HD6900's.
same issue here, i tried multiple crossfire modes and multiple different options in radon settings. all with the exact same result.

i have a 290x CF
Yes...this is the support forum...I need support on my AMD Crossfire. Thank you Mr. Troll for your advice in upgrading my video cards to ones produced in the last 24 hours....don't know why I let mine get more than 1 year behind. You may now go back under your bridge in St. Petersburg.
J/K...hehehe.
Howdy!

We support AMD and Nvidia for StarCraft II. This is a known issue that our developers are aware of and looking to resolve in the near future. You could try the following workarounds to play with out Flickering:

- Play the game in fullscreen Windowed mode.
- Windowed mdoe

Thank you!
12/27/2017 08:19 AMPosted by Zuvykree
Howdy!

We support AMD and Nvidia for StarCraft II. This is a known issue that our developers are aware of and looking to resolve in the near future. You could try the following workarounds to play with out Flickering:

- Play the game in fullscreen Windowed mode.
- Windowed mdoe

Thank you!


OK that helped, but, any fix? I have a Alienware M18X R1, 2 x 6970M in Crossfire, i only have this problem in SC2
same issue with the flickering. Running two R9 280Xs in crossfire. Tried all sorts of in-game graphics settings, v-sync, resolutions, refresh rates, etc. Updated to latest amd drivers and still no dice. Was fine until this latest patch. Game is now unplayable
I'm in this club too. Bumping for interest.
Same problem with my RX 480's in Crossfire.
Same here (two 295x in crossfire). Blizzard's suggestion of running in windowed fullscreen works. Will be on the lookout for the next patch.
Same issue with 2 RX 580s. Bump.
it will not even install on a4. Your best solution is to use nvidia Graphics Cards, no trouble there.
Flickering strobes give me a headache! Makes this I paid for game unplayable. Please fix.
12/27/2017 08:19 AMPosted by Zuvykree
Howdy!

We support AMD and Nvidia for StarCraft II. This is a known issue that our developers are aware of and looking to resolve in the near future. You could try the following workarounds to play with out Flickering:

- Play the game in fullscreen Windowed mode.
- Windowed mdoe

Thank you!


It's well known that running in windowed mode disables crossfire, so it's no wonder it's a "work around". Might as well just disable it from CCC. But it's nice to know this is a pure developer bug since it saves me time trying to find a solution to a futile problem.
... 2 RX 580s.


Oh, how I envy you...

Join the Conversation

Return to Forum