macOS: Bad AirPods audio quality

Mac Technical Support
Hi.

I play StarCraft 2 on my iMac 5k, High Sierra 10.13.2, with AirPods.

When I launch StarCraft 2, the audio output quality on the AirPods is telephone quality.

My voice chat settings are either to disable voice chat, or to use the built in microphone. But StarCraft still seems to use the AirPods as an input device, each time I launch the client, reducing the AirPods's output quality.

To fix this, each session I must go to StarCraft 2's options menu > voice chat, and toggle either "Voice Chat Enabled", or what my input device is (landing on "Built-in Microphone"). Upon doing this once, or sometimes more, the AirPods will reconnect as only an output device, with full audio quality.

StarCraft 2 should respect my voice chat settings, and not enable audio input on the AirPods, when I first launch the client.
go to options -> sound > uncheck headphone mode voila!
Locking this thread since it's been inactive for about a year. Please be mindful of resurrecting older threads, a new or more recent thread can be created to continue the discussion.

Join the Conversation

Return to Forum