Mouse will not remain confined during game.

Technical Support
So I built a new computer over the last year.

Intel 5930k
ASUS Sabertooth TUF x99 motherboard
Corsair Dominator Plat 32 gig 4-channel kit
ASUS nVidia GTX 1080
Samsung 500GB SSD

I also upgraded my monitors to two Samsung 28" 4k monitors. I run my setup in 4k with the my desktop extended across both. I have tried differing graphics and mouse configurations and I CANNOT get the mouse to remain confined to the game screen while playing.

For myself, this makes Starcraft II unplayable as I DEPEND upon edge scrolling to navigate around the map. I have tried Windowed Mode, Windowed Mode (Full Screen), Full Screen Mode, I have tried mouse cursor lock Smart and On, I have changed the resolution from 4k down to 2k (1920x1080 is the correct definition of 2k). Nothing works.
In Full Screen Mode the cursor will not remain bound where my displays extend. In Windowed Mode (Full Screen) the cursor will not remain bound on the bottom and keeps wanting to bring up the Windows task bar.
Hi there Maddhawk,

I looked over this and hope to help you to get the mouse confinement issue under wraps. The first thing that comes to mind, is somehow the setting for this was disabled. You can find it in the game options under Mouse and Keyboard. Should be the 4th option in that menu.

Another thing to try is just to clear all settings to make sure they are not bugged.

Let me know if changing this at all helps.

/Nathardrick
Your first suggestion I had already tried. You can note that I mentioned changing the cursor lock option, which is the 4th option under Mouse and Keyboard.

I tried the reset and that has had no impact at all other than resetting all settings (as it is supposed to do). After going back in the mouse still behaves as noted above.

Full Screen Mode (any resolution)
-Mouse is unbound where my monitors extend, that is on the right hand side, and escape the game. This behavior is in menus, campaign interface, and in actual game.

Windowed Mode (Full Screen) - uses OS resolution settings
-Mouse is properly bound on the left, right, and top sides, but becomes unbound on the bottom edge. So if I want to use edge scrolling to scroll down I get the Windows Task Bar popping up instead. No edge scroll occurs.
HI again Maddhawk,

Just a question for that windowed mode. If you move the task bar only to the second monitor, is it still an issue to scroll down?

You say your monitor is extended, are you using Nvidia Surround for this? Could we try to disable the Surround function to see if it is still a problem.

I just want to help here, and if we can find the cause, more can be done. :)

/Nathardrick
I'd like to avoid moving the bar if I can, since then I'd need to move it back after exiting the game. Point is to have it all "simply" work. I am not using nvidia surround. I use the basic windows settings to extend the desktop to both monitors so they work as one ultrawide screen.

I like to keep my games on the primary screen and firefox on the 2nd.
Thing of it is, with my old system, using two monitors, I never had this problem. Of course that system ran at 1080. Turning down the resolution cause other funky problems. Only thing I can think of right now is to leave it in Full Screen mode and unplug the second monitor if I want to play Starcraft II. That said, ONLY Starcraft II is having this issue.

Diablo III, WoW, HotS, Counter-Strike Source, Civilization IV, none of those games have the same problem.
Hi Maddhawk,

While I tried to pinpoint what was the cause, I can at least help with a workaround.

You said one screen worked, a Quick way to turn off a screen while you play is pressing Windows + P and selecting the main screen only.

I know this is not a fix, and hope that you continue to respond here till we find an answer. Something else that may help is disabling Windows Full screen optimizations.
    • In the Blizzard App, select the Options drop down in the game tab and select Show in Explorer
    • Right-click on the game .exe and select Properties
    • Go to the Compatibility tab and check the box ‘Disable fullscreen optimizations’
    • Press Apply and OK


Let me know if anything helps.

/Nathardrick

Join the Conversation

Return to Forum