mouse not working in game

Mac Technical Support
Prev 1 3 4 5
Same issue, Macbook Pro 2012. Mouse/cursor works fine in every other app, just not SC2
Just FYI (sorry if this is already posted):

My problem since late Nov'18: Mouse cursor frozen in SC2
*** Workaround #1 (already posted): play SC2 in Window mode (not FullScreen).

OK this work around works BUT I still can't play SC2 in Window mode as I was used to using a LOT of the keyboard shortcuts to select Units etc. etc.
Many of these keystrokes actually have MacOS functions in Window mode and the SC2 shortcuts don't work (are over ridden).

I know one can install 3rd party Apps (e.g. Paula) to ensure the SC2 keyboard shortcuts override the MacOS functions but I'm not doing this just because SC2 has a bug.

*** Proper workaround #2 : go to MacOS system preferences, go to security & privacy, check the box beside the Sc2 icon to enable control, close and restart the game.....(credit to Moustro).
This works perfectly.

It's a new recent bug so Blizzard should fix SC2 so that this Accessibility feature is either turned on automatically or warn users that they have to change Settings. It's a hard Setting to find for most iMac users!

Also FYI - I run Win10 in Bootcamp on my iMac - SC2 works just fine Full Screen mode in Win10 on my iMac.

Hurry up Blizzard please - how hard is it to keep a mouse cursor working? :(
Blizzard....NO. The answer is a resounding no. I should not have to play games with privacy settings or be forced to play in windowed mode. You should FIX YOUR GOD DAMN GAME.
11/14/2018 04:18 AMPosted by Moustro
We figured out the problem yesterday. For us proud Mac users, go to system preferences, go to security & privacy, check the box beside the Sc2 icon to enable control, close and restart the game, and you should be good to go. GLHF


This worked for me :)
same problem here!
Just updated everything today and Wanted to play some StarCraft 2, HOWEVER, my mouse isnt responding to the game! The Cursor is only working on my Tablet for some reason! But I dont want to use that! What the hell is going on?!

Yes Im a mac user too.
Opened SC2 on my mac for the first time in a few months, updated, and now my cursor won't work in fullscreen mode. Running mojave OS.

Playing in windowed screen works but I would prefer full screen as my laptop display is already very small. (once in game, press command+M to minimize the window and play in windowed screen).

Blizzard please fix this glitch!
this guys haven't been able to fix the bug.... put your act together people! and make this game great again....
11/16/2018 07:34 AMPosted by Zuvykree
Howdy!

I want to make sure we are clear about how to fix the stuck mouse issue.

The first part of the fix to be able to utilize the mouse is using Command + M to switch to Windowed mode.

The main fix so you can utilize fullscreen again is the following: Go to System Preferences > Security & Privacy > Privacy > Accessibility. If StarCraft II is listed here, make sure it is checked. If the game is not listed here, you can proc the permissions prompt by checking the Disable OS Keyboard Shortcuts option in the Mouse & Keyboard settings of the game.

Once you do this you should be able to return to fullscreen with out issues. If you have any stuttering or other mouse issues make sure to start a new thread. I wanted to make sure I added this clarification as you shouldn't just be using Command + M, you need to do the second part to get the fullscreen mode back to normal.

Thank you!


From Macworld -
Accessibility permission, which appeared in earlier releases of macOS, let apps use features to monitor and affect how you interact with the system that are primarily designed to work with software that helps people with visual, auditory, or motion issues.

... Apple requires explicit permission, because it’s just these kinds of features that can be leveraged and abused by simpler malware that doesn’t dig deeply into exploiting the system, but could, for instance, try to capture your keystrokes.


Accessibility Permissions also let active apps interact with other apps in a similar way that anti-cheat software does on Windows10 games. So for instance SC2 could potentially be checking to see if you have any apps running called "cheat engine" or whatever if you give it permissions, then ban your account if it thinks you're doing things Blizz doesn't like. Or it could also be keylogging everything you type into stuff like Discord, or collecting usage data for everything else you do while playing Starcraft so their Analytics people have something to look over.. Basically when you give an app Accessibility Permissions you're signing away your privacy to that app and just hoping they don't misuse it.
There is a good reason Apple doesn't let apps behave this way by default and I am appalled that Blizz would just recommend you turn it on as a quick fix without notifying the community of the risks or, heaven forbid, just fix the damn bug.
ActiBlizzard does not need to know what !@#$ I watch or what other programs I run alongside Starcraft, and moving forward this kind of flagrantly anti-privacy behavior on their part is a deal-breaker for me. I ain't getting WC3RF and unless Blizz changes direction I ain't getting any of their future games either.

EDIT - If I didn't care about privacy or security I'd play on Windows. I, like many others, am a Mac user for a reason.
11/13/2018 07:58 PMPosted by coffeeco
Having the same issue. late 2015 Imac


having the same issue
Mouse stopped working 2 days ago. Was working fine. I have a Late 2014 iMac with Mojave 10.14.3.
11/13/2018 07:58 PMPosted by coffeeco
Having the same issue. late 2015 Imac

Same Here Feb.17.2019
Has this been fixed? I'm experiencing this problem for the first time tonight.
Hi I have a current 2018 Mac Book Pro. The mouse will not work in full screen mode. I get I can toggle <control + m> in and out of windowed mode and it works as windowed, but the cursor, even in "full screen" windowed mode, brings up other programs, the dock etc when I am playing, My MMR pathetic enough as it is, is suffering. Help!
Ok so this works!!!! Scroll down this thread to the blue text posted by Zuvykree.
I had to add an extra step. So this worked straight up for me when nothing else did:
1. Do the whole system preferences thingy Zuvykree describes.
2. Open SC2.
3. Use the SC2 menu pane, the one bottom right of screen and open <options>.
4. From there, select <full screen>, click accept and [for me at least] happy days!

I am only posting this as I followed Zuvykree's advice but used <control-M> to toggle on fullscreen.That did not cut it, I had to select it from the options screen as I described.
GLGLGLGL
Go to System Preferences > Security & Privacy > Privacy > Accessibility. If StarCraft II is listed here, make sure it is checked
Go to System Preferences > Security & Privacy > Privacy > Accessibility. If StarCraft II is listed here, make sure it is checked
So Starcraft just doesn’t work with Mac’s anymore? Seems very lame! Was my favorite game
03/03/2019 06:21 AMPosted by Qbantoss
Go to System Preferences > Security & Privacy > Privacy > Accessibility. If StarCraft II is listed here, make sure it is checked


Hey Thabian,

Have you tried this? Basically Apple introduced some new Privacy and Security features that need to be manually configured for some applications.

Join the Conversation

Return to Forum