My mouse cursor does not work inside SC

Mac Technical Support
Hello, my mouse cursor does not move when im in sc. im using a Imac and is the first time this happens to me. plese help :D
this is happening to me also, worked fine yesterday and this morning the mouse stops moving after hitting the play button. I am playing on a new MacBook Pro.
Yep. You log into the game and the mouse just sits there. Been like it for like three days for me. thought the update this morning would be a fix but it wasn't. Can't play the game at all.
I am having the same problem
has anyone gotten an answer yet about this? iMac too - I have to physically turn the computer off to get out of the program, nothing works once I start SC2
Thanks for the report, everyone! Just to make sure, has everyone tried the steps here? There is a known issues for Mac OS and the Mouse in Heroes of the Storm and Starcraft II.
11/13/2018 12:43 PMPosted by Zhyxen
This sounds like it may be related to the mouse issues we're getting reports on the Heroes of the Storm forums about. The fix so far has been to make sure the game has Accessibility permissions.

For that you’ll want to go to System Preferences > Security & Privacy > Privacy > Accessibility. If Starcraft II is listed here, make sure it is checked. If the game is not listed here, you can proc the permissions prompt by checking the Disable OS Keyboard Shortcuts option in the Mouse & Keyboard settings of the game. This would need to be done in windowed mode. You can switch to windowed in-game using Command + M.
The above solution also works for similar mouse problems in Diablo 3 under Mojave (10.14.2).

Join the Conversation

Return to Forum