Mouse/Trackpad not working

Mac Technical Support
Anyone else having an issue where your mouse or trackpad won't work after installation of the latest patch?

I played yesterday, but just logged in and my cursor won't move. The keyboard works since I hit the escape key the menu pops up, but I can't select anything. I plugged a mouse into my laptop and it doesn't help. I restarted my laptop and still no joy.

The button works. I was curious how to get the game to quit so I windowed out of SCII moved my mouse manually to where the "exit game" button is in game. windowed back into SCII and clicked the mousepad and the game exited.

Mac OS 10.14 Mojave
I'm having this issue. Played this morning. Patch installed, and the mouse is frozen in the corner of the screen, but won't move. May be in the background, and all of the Mouse support on the site seems to be for Windows OS.
Yup, after the patch my both mouse and trackpad won't move. Clicking works though. I'm on macos Mojave.
I'm on the latest update of iOS as well and my mouse isn't working either. bust in the patch...
Marked As Solution
This sounds like it may be related to the mouse issues we're getting reports on the Heroes of the Storm forums about. The fix so far has been to make sure the game has Accessibility permissions.

For that you’ll want to go to System Preferences > Security & Privacy > Privacy > Accessibility. If Starcraft II is listed here, make sure it is checked. If the game is not listed here, you can proc the permissions prompt by checking the Disable OS Keyboard Shortcuts option in the Mouse & Keyboard settings of the game. This would need to be done in windowed mode. You can switch to windowed in-game using Command + M.
mouse works in windowed mode. use command + M
the above worked for me from Zhyxen
Accessibility permissions fixed it.
Yep, frozen
Zhyxen. Privacy settings are correct, still no mouse.
11/13/2018 01:08 PMPosted by Graham
Zhyxen. Privacy settings are correct, still no mouse.

Have seen one case where someone had to remove the game from the Accessibility list then restart the game and re-add it. May need to do that here.
Zhyxen, that didn't work.
It did work for me too thank you Zhyxen. (Guys don't forget to unlock at the bottom left of the accessibility window (I lost 10 minutes because of that hahaha)
yep. I'm using a MacBook Pro Mojave and I've never had a mouse issue in the last 8 years and then today, after installing the latest patch, my mouse freezes when I start my SC2. Accessibility permissions did not fix it.
Zhyxen you legend xx Yeah that worked for me, it was already checked, so i unchecked, then checked it back. thanks dude
- Accessibility permissions fixed it.
- Also, deleting SC from the Accessibility list and re-adding it fixed it as well.
Thanks!
thank you Zhyxen your solution worked for me XD
thank you it worked for me
Worked, thanks! Not sure what sort of black magic you guys are doing that requires accessibility access to use my mouse, though...
Woo hoo. Control M for all you Mac guys out there!

Join the Conversation

Return to Forum