Cannot move mouse since 4.7 when fullscreened

Mac Technical Support
As the title says, the mouse or trackpad cannot move while the SC2 screen is active and full screen.

I recently upgraded to Mojave, but it was not an issue on 4.6, as I could still play fullscreened.

The mouse still works just fine on any window that isn't SC2, and command-tabbing out of SC2 lets me move the mouse again.

But once I pull SC2 up again, the mouse is stuck in place. I can still freely click buttons, but cannot move the cursor around. After multiple tab outs and tab in to position the mouse, I was able to switch to windowed, and the mouse now responds properly in game.

The mouse also responds properly in windowed (fullscreen).

I would prefer not to play windowed though, so any help would be appreciated.
I have the same problem :(
The cursor is frozen no matter if I try to use the trackpad, Magic Mouse or wired mouse.
Marked As Solution
11/13/2018 12:43 PMPosted by Zhyxen
This sounds like it may be related to the mouse issues we're getting reports on the Heroes of the Storm forums about. The fix so far has been to make sure the game has Accessibility permissions.

For that you’ll want to go to System Preferences > Security & Privacy > Privacy > Accessibility. If Starcraft II is listed here, make sure it is checked. If the game is not listed here, you can proc the permissions prompt by checking the Disable OS Keyboard Shortcuts option in the Mouse & Keyboard settings of the game. This would need to be done in windowed mode. You can switch to windowed in-game using Command + M.


This seems to fix it
Thank you, it worked!
Confirmed. Worked for me as well
Why should I give SC2 accessibility permissions just to gain basic functionality that every other game in my library has by default?
I can expect better performance from games developed for Windows then ported over by the likes of Feral or Aspyr than I get from Blizz at this point and I hate it. I don't even run into issues this bad when playing winewrapped games.
Cannot find this string, What do you mean by preferences. I am on windows 10 btw
If I've said it once I've said it a hundred times.
You shouldn't have to give a game accessibility permissions to gain normal functionality. The cause is probably a flaw in anti-cheat spyware or something, and if you give Starcraft 2 Accessibility Permissions then you're letting the program read everything else you have going on while you play - That includes what you write on Discord or Skype, it includes what other applications you have going on while you play, or even stuff you do in a web browser.
ActiBlizz likes having all that info because megacorp analytics is part of the business and customer data is a high value commodity, but it's totally unethical for them to ask for all that data just as a quick-fix for their own awful implementation.

Stop letting game devs get away with this crap. They'll never fix it if you let them get away with leaving the problem be.

Join the Conversation

Return to Forum