Mouse Jitters Like Crazy Mac OS Mojave

Mac Technical Support
Hi all, I've been having a really annoying problem lately. My mouse will frequently become nearly unresponsive. When I try to move it around (particularly in the menus) it just jitters around in one spot. Sometimes it will work, but moves VERY slowly. This only happens in SC2, and happens with every mouse I've tried. Frustratingly, I threw away one mouse, thinking it was the problem.

I've seen a few threads from 2017 reporting this issue in High Sierra, but none of the steps recommended fixed my problem. Anyone else having trouble with that anymore? Any word on an official fix from Blizzard?
This is the thread I referred to in my post. None of these steps seem to fix my issue.
https://us.battle.net/forums/en/sc2/topic/20759247246?page=1
Hey, bobthunicorn! Thanks for starting up a new thread! The initial issue on that thread should be fixed.

Just to ensure, has Windowed mode been tested? (CMD+M) If this works, Windowed mode will work as well for the "Fullscreen" workaround.

There are cursor issues that we've seen in StarCraft II, Heroes, and Diablo II. If the Windowed mode does not resolve the issue, let's try checking the "Confine Mouse Option," since this can cause the cursor to be unresponsive in Windowed mode too.

In StarCraft II, go to Options > Mouse and Keyboard. Locate "Confine Mouse Cursor" and set it to Off. Retest for a bit and see if there's any unresponsive behavior!
Tried both. The first made the game almost unresponsive due to severe lag. The second had no affect on the mouse lag.
Is there any actual fix coming for this? Or just a bunch of workarounds that don’t work for everyone?
Hey, bobthunicorn! This seems like a different issue to the cursor stuck issue that we have been seeing. With it jitter and being slow, but almost unresponsive, it sounds like there's a different cause than the ones we've been seeing. There's a few steps that can help.
  • Reset the in-game options
  • Press ESC, go to Options. Toggle V-sync on, test then switch it back off.
  • Set the Graphics API under Options to Metal.
  • Under Mouse and Keyboard Settings, select Reduce Mouse Lag
  • Lower the Resolution
  • Does this happen in Windowed mode?

Feel free to skip the steps that you've already tried. If it continues, what's the Model for the Mac? What steps have you tried so far?

Join the Conversation

Return to Forum