BLZBNTAGT00000907/BLZBNTAGT000008FC, missing Play Button

Technical Support
So i still have all the files on the PC but suddendly the launcher cant find SC2 and Remastered files anymore. Only have the option to install, clicks install and nothing happens. Clicks locate game files and selects SC2 file, nothing happens. Played it last week just fine. No update what it can find and my other games works (Diablo and Overwatch).
Just wanted to ask if anyone have an easy fix before I contact Tech Support
this
Thanks for your reports everyone! We're currently seeing issues with the Application missing the play button, or getting errors: BLZBNTAGT00000907, BLZBNTAGT000008FC. Went ahead and changed the title of this thread to reflect the issue better. It can affect agent related tasks like installing/locating the game files, as well as installing or launching the Blizzard Application. This is primarily for those who have Hearthstone, Heroes of the Storm, or StarCraft II.

Any troubleshooting or reinstalling of the application is causing issues with it installing or launching the Blizzard Application. Please avoid troubleshooting the issue for the time being.

Our team is currently investigating the issue. We'll provide updates when available!
Quick fix for sc2 addict : Launch the game from the map editor works on my side.
Same here.

04/23/2019 12:38 PMPosted by Calleo
Just wanted to ask if anyone have an easy fix before I contact Tech Support
There's a workaround:

  • go to the SC2 installation folder
  • chose the "Support64" folder
  • execute the "SC2Switcher_x64.exe" file
  • (described by Nachtspion in the German Hearthstone forums)

    Edit: @Caterpepi: as far as I'm concerned, SC:R seems to be affected, too.
    Just displaying this in the launcher would have saved me some frustration over the last 15 minutes.

    So just as an idea:
    Maybe show a link to this to everyone on the SC2 tab.

    Because otherwise i would bet a lot of people will try reinstalling and might get REALLY frustrated depending on their connection speed.

    Update:
    Also starting via SC2Switcher_x64.exe works for me too.
    Thanks, Quotenfrau! We're seeing some reports now with SC:R and we'll get a thread up to track SC:R reports as well :) No new updates to provide currently, but please try the following workaround provided by Quotenfrau:
    04/23/2019 01:49 PMPosted by Quotenfrau
    There's a workaround:

    go to the SC2 installation folder
    chose the "Support64" folder
    execute the "SC2Switcher_x64.exe" file
    We have pushed a fix live for this issue. Please try the following steps:
      1. Close the Blizzard Application
      2. Wait 30 seconds to 1 minute. <- Important, if you do not do this, the application will not fully exit.
      3. Restart the Blizzard Application

    You should see immediate relief after restarting, if not, please wait 5-10 minutes and redo the steps. If it persist after trying these steps, let us know!
    i tried restarting after 2 minutes and it didnt work. After i tried it again after another 5 Minutes, it is still not working :(
    Hey, Sipher! Was the computer restarted or just the application? We're seeing positive reports of restarting the computer, waiting a few minutes, and retrying.
    Restarting the app, and then restarting the computer did not succeed on an up-to-date Mac.

    Pressing PLAY in the Battlenet app shows "Launching" briefly, then just goes back to showing PLAY...
    Have been having this for the past 4 hours, I can't open the editor or anything either.

    Every time something goes wrong a popup displays the error code, which if you click goes to a page that does not exist, can't you at least point to something if you are going to create a bug number/page?

    Offline mode doesn't work because it is not recognizing the game as installed too, even after I use the "Already installed?" locator.

    This is the kind of problem we DO NOT WANT when we are trying to play a local (LAN) or singleplayer campaign, which is all I want. How can Blizzard still mess with SC2 so many years after launch?

    Avoided blizzard for years because of battle.net .. purchase SC2 campaign a week ago only to bump into this. Kudos, then people wonder why nobody wants Epic Store or other always-online stuff with their software.
    @Winky, this sounds like a different issue than the ones we have been seeing here. Could you try the steps available here and start a new thread?
    @Sathella, the issue should be resolved now, all thats needed is for the patch to be pushed to the Blizzard Application. If the problem is persisting after the steps mentioned above, please try the steps here. We have also had reports of running it as admin resolving the issue.
    I normally don't complain about stuff like this but this sucks on so many levels. Now I was finally able to play two games but now I cannot queue again and I cannot even watch a fffffreakin' REPLAY.

    I hope you can prevent this from happening again. Or at least make replays watchable without any internet connection
    Correction: I can now watch a replay but only after restarting and not trying to queue

    Join the Conversation

    Return to Forum