4.8.5 Game Crashes when starting

Mac Technical Support
Worked for me. Mac OS 10.14.4.

04/23/2019 08:04 PMPosted by Tyravangelon
Same problem on Mac OX 10.13.6 High Sierra, MacBook Pro 2013.

Update:
This has been a problem previously, and by looking around the Forums I found the solution to be:
- On Mac Apple menu, go to System Preferences/Sharing
- Change Computer Name to something different.
- Click on Edit and then Okay.
- Close Preferences window.
- Game should now work
You can change Computer Name back to what it was originally and it should still work. In fact, you may not even have to change the Computer Name, just going through the steps might be sufficient.
04/23/2019 08:04 PMPosted by Tyravangelon
Same problem on Mac OX 10.13.6 High Sierra, MacBook Pro 2013.

Update:
This has been a problem previously, and by looking around the Forums I found the solution to be:
- On Mac Apple menu, go to System Preferences/Sharing
- Change Computer Name to something different.
- Click on Edit and then Okay.
- Close Preferences window.
- Game should now work
You can change Computer Name back to what it was originally and it should still work. In fact, you may not even have to change the Computer Name, just going through the steps might be sufficient.
04/23/2019 08:04 PMPosted by Tyravangelon
Same problem on Mac OX 10.13.6 High Sierra, MacBook Pro 2013.

Update:
This has been a problem previously, and by looking around the Forums I found the solution to be:
- On Mac Apple menu, go to System Preferences/Sharing
- Change Computer Name to something different.
- Click on Edit and then Okay.
- Close Preferences window.
- Game should now work
You can change Computer Name back to what it was originally and it should still work. In fact, you may not even have to change the Computer Name, just going through the steps might be sufficient.


This worked for me after trying everything else, thank's for the tip!!
Worked for me! I reinstalled for nothing.
This worked for me with a 2018 mac mini running 10.14.4. Was having issues with SC2 & HotS and renaming the computer name worked like a charm.
After going through everything up to deleting and reinstalling everything and trying it on another account sure enough changing the sharing name worked. Awesome.
04/23/2019 08:04 PMPosted by Tyravangelon
Same problem on Mac OX 10.13.6 High Sierra, MacBook Pro 2013.

Update:
This has been a problem previously, and by looking around the Forums I found the solution to be:
- On Mac Apple menu, go to System Preferences/Sharing
- Change Computer Name to something different.
- Click on Edit and then Okay.
- Close Preferences window.
- Game should now work
You can change Computer Name back to what it was originally and it should still work. In fact, you may not even have to change the Computer Name, just going through the steps might be sufficient.


This did not work on my 17,1 iMac. The game still quits on start-up.

Process: SC2 [18808]
Path: /Applications/StarCraft II/*/SC2.app/Contents/MacOS/SC2
Identifier: com.blizzard.starcraft2
Version: 4.8.6 [73620] (73620)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: SC2 [18808]
User ID: 502

Date/Time: 2019-04-26 22:30:38.614 -0500
OS Version: Mac OS X 10.13.6 (17G6030)

Model: iMac17,1, BootROM 164.0.0.0.0, 4 processors, Intel Core i7, 4 GHz, 32 GB, SMC 2.34f2
Graphics: AMD Radeon R9 M395X, AMD Radeon R9 M395X, PCIe
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1867 MHz, 0x802C, 0x31364B544631473634485A2D314739453220
Memory Module: BANK 0/DIMM1, 8 GB, DDR3, 1867 MHz, 0x802C, 0x31364B544631473634485A2D314739503220
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1867 MHz, 0x802C, 0x31364B544631473634485A2D314739453220
Memory Module: BANK 1/DIMM1, 8 GB, DDR3, 1867 MHz, 0x802C, 0x31364B544631473634485A2D314739503220
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x14A), Broadcom BCM43xx 1.0 (7.77.37.32.1a1)
Bluetooth: Version 6.0.7f12, 3 services, 27 devices, 1 incoming serial ports
Network Service: iPhone, Ethernet, en5
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: APPLE SSD SM0512G, 500.28 GB
Serial ATA Device: OWC Electra 6G MAX, 1.92 TB
USB Device: USB 3.0 Bus
USB Device: ASMT1153e
USB Device: My Book 25EE
USB Device: USB3.0 Hub
USB Device: VectoTech
USB Device: USB3.0 Hub
USB Device: Bluetooth USB Host Controller
USB Device: FaceTime HD Camera (Built-in)
USB Device: USB2.0 Hub
USB Device: iPhone
USB Device: USB2.0 Hub
USB Device: Gaming Keyboard G910
USB Device: G500
Thunderbolt Bus: iMac, Apple Inc., 28.1
The name change thing works for me. How did anyone figure that would do it? It doesn't seem even remotely connected to the game.
Worked for me, thanks!
Hey everybody,

We actually have people looking into this as a bug right now. We noticed this with Heroes of the Storm a bit ago too. Basically, there's something up with how the Starcraft 2 engine is reading your Mac OS profile name. I'm quoting the work around one of our players found for more visibility, but this should fix it.

This has been a problem previously, and by looking around the Forums I found the solution to be:
- On Mac Apple menu, go to System Preferences/Sharing
- Change Computer Name to something different.
- Click on Edit and then Okay.
- Close Preferences window.
- Game should now work
You can change Computer Name back to what it was originally and it should still work. In fact, you may not even have to change the Computer Name, just going through the steps might be sufficient.


Thanks for posting this Tyravangelon!
04/23/2019 08:04 PMPosted by Tyravangelon
Same problem on Mac OX 10.13.6 High Sierra, MacBook Pro 2013.

Update:
This has been a problem previously, and by looking around the Forums I found the solution to be:
- On Mac Apple menu, go to System Preferences/Sharing
- Change Computer Name to something different.
- Click on Edit and then Okay.
- Close Preferences window.
- Game should now work
You can change Computer Name back to what it was originally and it should still work. In fact, you may not even have to change the Computer Name, just going through the steps might be sufficient.


Thanks!! Crazy as it may sound, but it worked for me!
Worked for me as well. Weird how something "seemingly" totally unrelated breaks the application. Thanks for the help!
04/23/2019 08:04 PMPosted by Tyravangelon
Same problem on Mac OX 10.13.6 High Sierra, MacBook Pro 2013.

Update:
This has been a problem previously, and by looking around the Forums I found the solution to be:
- On Mac Apple menu, go to System Preferences/Sharing
- Change Computer Name to something different.
- Click on Edit and then Okay.
- Close Preferences window.
- Game should now work
You can change Computer Name back to what it was originally and it should still work. In fact, you may not even have to change the Computer Name, just going through the steps might be sufficient.


Thanks this worked for me.
04/27/2019 03:14 PMPosted by Drakuloth
Hey everybody,

We actually have people looking into this as a bug right now. We noticed this with Heroes of the Storm a bit ago too. Basically, there's something up with how the Starcraft 2 engine is reading your Mac OS profile name. I'm quoting the work around one of our players found for more visibility, but this should fix it.

This has been a problem previously, and by looking around the Forums I found the solution to be:
- On Mac Apple menu, go to System Preferences/Sharing
- Change Computer Name to something different.
- Click on Edit and then Okay.
- Close Preferences window.
- Game should now work
You can change Computer Name back to what it was originally and it should still work. In fact, you may not even have to change the Computer Name, just going through the steps might be sufficient.


Thanks for posting this Tyravangelon!


Yeah, that didn't work for me. I even tried restarting after the name was changed and kaboom, Starcraft 2 quits immediately on startup.
04/28/2019 09:44 AMPosted by EricTheRed

Yeah, that didn't work for me. I even tried restarting after the name was changed and kaboom, Starcraft 2 quits immediately on startup.


It looks like you are getting an e_fileCorrupt error. Have you tried a repair or reinstall of SC2?
Worked for me
04/23/2019 09:04 PMPosted by Gyalgatine
Same problem on Mac OX 10.13.6 High Sierra, MacBook Pro 2013.
Wow that "sharing" Change mac name fixed it immediately. Thanks man!

Update:
This has been a problem previously, and by looking around the Forums I found the solution to be:
- On Mac Apple menu, go to System Preferences/Sharing
- Change Computer Name to something different.
- Click on Edit and then Okay.
- Close Preferences window.
- Game should now work
You can change Computer Name back to what it was originally and it should still work. In fact, you may not even have to change the Computer Name, just going through the steps might be sufficient.


Just tried it, did not fix my issue. Lets see if it works for others. Thanks!
04/28/2019 01:06 PMPosted by Zenlaka
04/28/2019 09:44 AMPosted by EricTheRed

Yeah, that didn't work for me. I even tried restarting after the name was changed and kaboom, Starcraft 2 quits immediately on startup.


It looks like you are getting an e_fileCorrupt error. Have you tried a [url="https://us.battle.net/support/article/7655"]repair[/url] or reinstall of SC2?


I have no idea how to reinstall the app, but yes, I did just try to repair following your instructions and Startcraft2 continues to immediately crash on start-up.
@EricTheRed, the crash that StarCraft II is throwing is different from the one we're tracking on this thread. To keep this thread linear with the quit unexpectedly error, would you be able to start a new thread or contact our Technical Support directly with the SPX files? It looks like there's some timing loops that we'll want to look into individually.
04/30/2019 01:55 PMPosted by Caterpepi
@EricTheRed, the crash that StarCraft II is throwing is different from the one we're tracking on this thread. To keep this thread linear with the quit unexpectedly error, would you be able to start a new thread or [url="https://us.battle.net/support/en/help/product/starcraft2/234/240/channels?utm_source=internal-TechForum&utm_medium=posting&utm_campaign=BlizzardCS&utm_content=contact"]contact our Technical Support directly [/url]with the[url="https://battle.net/support/article/12988?utm_source=internal-TechForum&utm_medium=posting&utm_campaign=BlizzardCS&utm_content=solution"] SPX files[/url]? It looks like there's some timing loops that we'll want to look into individually.


Okay. I started a different thread with my entire crash log on it here: https://us.battle.net/forums/en/sc2/topic/20771546975?page=1#post-2

Join the Conversation

Return to Forum