Razer Naga Mouse Problems

Mac Technical Support
It's a bit more complicated than what was first thought, because it is not a direct correlation. They are looking and trying to see what is causing this disconnect, which is why Apple is also going to see what is going on. No ETA but at least the issue has been recognized and being investigated.
________________________________________________
Mac Tech Support || Tues-Sat 9 AM - 5 PM CST
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Show some love to this boomkin
Blizzard Blues don't /dance, we /boogie.
My name is TonyM but you can call me Tony Mac, no seriously, they call me that..
Thanks guys for such speedy replies! Hopefully all will be well in time! I thought it was alittle ironic that razer's peripherals would cause this kind of hiccup! Oh well! Technology can't always be perfect!

Anyways, thanks again! Can't wait to hear the solution (Or feel the effect of a patch/tech thingy that fixes problems)
Just to add, I think this applied to any gaming mice that has # keys on it. I've heard misc reports of other brands, which is another reason why Apple is coming into the picture.
________________________________________________
Mac Tech Support || Tues-Sat 9 AM - 5 PM CST
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Show some love to this boomkin
Blizzard Blues don't /dance, we /boogie.
My name is TonyM but you can call me Tony Mac, no seriously, they call me that..
*Sigh* i named my razer naga "Disfunctional" still a wonderful mouse....but unable to function normally in SC2.
Yea I was thinking I'd done something to my mouse as well. WC3 has the same problem as SC2 although the naga never worked in WC3 to begin with. Looking forward to a fix.
I was looking into the 1.3 patch. If I read the PTR's overview, it seems like we will have a solution soon!

edit: I made a mistake, in a future patch we will get a fix.
Def takes some getting used to now
Just wanted to add that this same issue is also happening with my Logitech MX Revolution mouse, logitech control center v3.3.0.

Hi. I didn't want to start a new thread about my question because I didn't feel like it needed one; but it is a mouse question.

I use a wireless logitech mouse on my MacBook Pro. And whenever I get into games, the mouse movement and sensitivity is really bad. Precision is way off, and it's just outright impossible to play at the speed I'm used to (even though I'm not very good). It's almost like having the old ball mouses and the ball getting stuck or jammed so the computer doesn't read the movements properly. For example, I could move my mouse from my Nexus to the mini map, and the mouse stops moving halfway or is a lot slower than the actual movement of my hand.

Does anyone know how I might be able to fix this? I realize that having a wired mouse would probably be way better, but I can't get one right now. I've used the same mouse on an HP dv6 notebook and it works perfectly fine.
Are these USB wireless mice? I think this is a different issue then. I'm trying something similar like this on the WoW forums.

http://us.battle.net/wow/en/forum/topic/1118392118

Try reading this to see if your issue is similar to this.
________________________________________________
Mac Tech Support || Tues-Sat 9 AM - 5 PM CST
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Show some love to this boomkin!
It's the return of the Mac, you know that i'll be back, oh oh ohhhh!!
They call me TonyM, but you can call me Tony Mac. No seriously, they call me that.
yes it is a usb mouse. looks interesting, guess i'm not the only one with these problems. from the skim so far, i stand exactly in the same spot as many of those people. the mouse works perfectly even in the menu. but when i start a game, it becomes unusable at times. i'm losing games where i don't normally lose! )=<

but thanks! i'll take a read and see if anything helps!

EDIT: i don't play WoW so i can't post on those forums, but if it is any help i will take the issue format there and re-post it here just to help you guys in case it is a reoccurrence for 2011 models like mine.

1. mouse movement is very choppy and inaccurate. clicks sometimes don't register. it's almost exactly like having the old ball mouses and the ball getting jammed so the computer does not read the movements. it works outside the game, in the game menu. but when i go to actually play a game, then all hell breaks loose )=

2. Your system specs
MacBook Pro 13" 2011 i5

Hardware
Model Name: MacBook Pro
Model Identifier: MacBookPro8,1
Processor Name: Intel Core i5
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 4 GB
Boot ROM Version: MBP81.0047.B04
SMC Version (system): 1.68f96

Graphics/Displays
Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 384 MB
Vendor: Intel (0x8086)

Software (remove the Computer Name and User Name lines)
System Version: Mac OS X 10.6.6 (10J3210)
Kernel Version: Darwin 10.7.1
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 10:57

c. Exact Model of mouse, and if it is USB or wireless
Logitech, wireless USB. unfortunately, i'm not sure what the exact model is. but judging from the mice on the logitech site, it looks extremely similar to the wireless M305. i'm guessing mine is just an older version.

3. What you have tried to do to resolve this issue (see example below)
replaced batteries
adjusted in game settings as well as mouse settings on system preferences
i'm not too familiar with many of the things that people have talked about and tried (such as nuking WTF, etc) so i don't know how to do them
i'll look over the things that i do know and give those a try too.

UPDATE: i turned bluetooth off and the mouse works slightly better. but when i get into the midgame and there are more units out.. it goes back to the chopiness.
Thanks for the post, and this is exactly what I was looking for. I will add this to my tracking. Thanks!
________________________________________________
Mac Tech Support || Tues-Sat 9 AM - 5 PM CST
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Show some love to this boomkin
It's the return of the Mac, you know that i'll be back, oh oh ohhhh!!
My name is TonyM but you can call me Tony Mac, no seriously, they call me that..
Any updates on fixing this Naga issue? I can't ladder until it's fixed! Heck, I don't even like playing the game... PLEASE FIX IT!!
Any luck on a fix? I'm so much worse when I use regular keybinds.
almost two weeks since we were last updated. any news?
Hopefully this maintenance tonight will fix the problem! if not i will be super upset!
Uhm, after patch 1.3.0 I still have nothing. More of just a status update than anything. To be honest, I've sort of learned to play without. But still hoping there will be a fix in the future. If anyone had it fixed with this patch could you let me know. perhaps there is a setting I've yet to enable.

I'll try to check the status about this and get more info.
________________________________________________
Mac Tech Support || Tues-Sat 9 AM - 5 PM CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my service. Haala at your boi
Mac Blue will make you JUMP JUMP
Tony Mac will make you JUMP JUMP
Blue Posts will make you JUMP JUMP
Thanks.

Join the Conversation

Return to Forum