Razer Naga Mouse Problems

Mac Technical Support
I am sorry that we do not have an ETA on a possible fix. We just ask that you be patient and know that we care about our customers and their game experience. We here at Blizzard and the Mac Tech team will do everything we can to make sure it is as soon as possible. =)

________________________________________________

Klint P
ATS - Mac Tech

The Restrooms are for paying customers only.

Cannot find a resolution on the forums, contact a Support Rep directly:
http://us.blizzard.com/en-us/company/about/contact.html
https://www.surveymk.com/s/TKL88F8
the fix is to install latest naga drivers, which works around blizzards work around to an apple bug. blizzard intentionally broke the naga to fix another problem, collateral damage, naga, forced to take action since blizz wasn't gonna revert their change, updated driver to work around the work around. does that make sense?
So installing the latest firmware/drivers will fix the issue of the side buttons not working in games?
Bump
Tried both, using the side keys worked with typing in chat rooms ect, but not in any game I play :(
So since 2011 did it get fixed? I'm having same issue now. Specifically in Windows 8 I think it happens when I click tab and middle button. I think it's shortcut to task bar or something
So it looks like this still isn't fixed after 3 years of supposedly working on the problem. I really have to wonder where the priorities are with the tech team.
In the meantime you can use this fix I found on the world of warcraft forums to get your control groups working with the modifier keys.

There's an easy way to fix this with just razer synapse and no addons. You simply use the macros in razer synapse.

Go to macros, create a new macro by clicking the '+' and entitle it Numpad 1. Select default delay and set it to whatever you want (i use 0.050 sec delay). then click record and press 1 on the side of your razer naga once, then click stop record.

Go to Mouse and under customize select "go to side view". click the tab for NUM to switch to the numpad tab instead of normal keys (123), then select 1. Under button assignment select macro, then assign the Numpad 1 macro you just made and under Playback option select "Play while assigned key is pressed". Voila, modifiers now work for that key.

You can use this same method for enabling modifiers for all other Numpad keys, and for any of the 1-0 keys on your naga. I personally setup these macros for both sets so modifiers work for both modes. Hope this helps.
You don't need that, just install and launch https://pqrs.org/osx/karabiner/

Fixed everything for me :)
its nice to see this issue was never actually resolved.
I wish it would work by now.. well i guess its time to quit starcraft after waiting 2 years for this so sad.

Join the Conversation

Return to Forum