Virtual memory problems

Technical Support
Hey, hoping someone here could help with a really annoying issue.

Since installing the game, I've been having severe issues with virtual memory. SC2 keeps insisting it needs more, so I gave it about an extr 500 MB of it twice... and it's still not enough. I'm a little nervous about just giving the PC more and more virtual memory if there is something else at fault.

Current rig is:
AMD Phenom 9950 Quad-Core, 2.6 GHz
About 3 Gigs of memory available (3.328 to be precise)
ATI Radeon HD 4870, 1 Gig of memory (drivers are definitely up-to-date; SC2 warned about it right off)
Virtual memory is at 3400 initial, 6000 max.

Should I increase the initial and/or max virutal memory? Or is something else going on that I need to check?
Just an FYI, the message I'm getting is as follows:

Your computer is running low on paged pool memory. Visual quality may degrade. To improve performance, some of your graphics settings have been adjusted automatically. Manually lowering your graphics settings further and restarting StarCraft II or closing other applications may also help.
I'm getting the same message....

My rig is :
AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ 2.6 GHz
2.00 GB of Ram
NVIDIA GeForce 9800 GTX/9800 GTX+
Virtual memory is at 1000 initial, 10000 max

No matter what graphics setting i use, it runs out of paged pool memory, though at lower settings it takes longer. Is there a glitch in the system where it doesnt purge the memory after its not being used?

Edit: also im not sure if it is an attributing factor but i am using windows xp
Gotta keep this issue bumped. Common Blizzard at least say you're looking into it.
Bump. Same Low paged pool pop up for me.
No reply from tech support email that I was given. No reply on any forum that the issue is even being acknowledged or looked at.

That's okay. I see they are busy with other things. When they decide to fix the problem, I'll tell people not to avoid the game like I have been, and trashing it on various review sites and whatnot.

I mean, they suckered me out of my hard-earned money. No reason to let them go on suckering other folks out of money for a game their system won't even run, right?
Bump

Cmon Blizz! I wanna be able to play on higher than minimum settings for more than 20 minutes.....fix the problem!!
I had the same problem too. However I learned how to fix it from some other person on here. (Sorry for not remembering your name but all credits go to you)

If you are running the Windows XP edition (like I am) you most likely have the same problem I did. First off you should check your paged pool memory, Go to the control panel and click on system. Then click on the advanced tab, click on the settings tab in the performance pane. Go through all the tabs here and set it so windows chooses whats best for you. Then you have to go into your registry, to do this go to run and type in "regedit". In there go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management. once there edit the pagedpoolsize to ffffffff. That should fix it for you, at least it did for me. If it doesn't then I don't have a clue, since I have tried everything I know to fix it.

Again I did not figure this out on my own, someone else posted it somewhere and for the life of me I can't remember their name.
Like Setzway said, let windows control it. There is no reason to be afraid, your system will run much better letting windows control it. Also make sure you have plenty of room for the swapfile on the drive.
If anyone is having to use excessive amounts of paged memory... You need a RAM upgrade. Seriously. If you have plenty of RAM, then you won't use paged memory. (paged memory is a file on your hard drive. Also much slower than actual RAM. Thus slowing you down)

Especially if you are a gamer. More memory, the better.
I had the same problem too. However I learned how to fix it from some other person on here. (Sorry for not remembering your name but all credits go to you)

If you are running the Windows XP edition (like I am) you most likely have the same problem I did. First off you should check your paged pool memory, Go to the control panel and click on system. Then click on the advanced tab, click on the settings tab in the performance pane. Go through all the tabs here and set it so windows chooses whats best for you. Then you have to go into your registry, to do this go to run and type in "regedit". In there go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management. once there edit the pagedpoolsize to ffffffff. That should fix it for you, at least it did for me. If it doesn't then I don't have a clue, since I have tried everything I know to fix it.

Again I did not figure this out on my own, someone else posted it somewhere and for the life of me I can't remember their name.


I'll give this a shot tonight. Thanks.

Join the Conversation

Return to Forum