Connect Button is disabled, can't login

Mac Technical Support
My Macbook Pro died, and I ordered a new one, downloaded and installed SC 2 and patched it.

When I type in my username the connect button stays disabled and I can't click on it.
I tried launching the SC 2 Editor and authenticate from there but it says it failed to log me in.

I've reset my account password, and it still fails to log me in.

Suggestions?
Make sure you are using your Battle.net email address, as the connect button will not respond to anything else other than an email address.

Ex: name@myisp.com
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
I'm one of the four sheep of the apocalypse.
Horses aren't as scary anyways.
BRAAAAAAIIIINNNSSSS!
Im having the same problem. The whole thing works on my other computer which is still downloading the current patch..i think the new patch disables you from playing without paying more money to blizzard for Hots upgrade.? Can i get some help
Is your game full up to date on the launcher?

Other than not typing in the email correctly, I've seen it remain grayed out when permissions are incorrect. Try resetting them to see if this helps.

Resetting permissions on the Starcraft II folder
    1. Select the Starcraft II folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items
Hey you guys this was really helpful, thanks a lot. I'm on deployment at the moment and just got it to work.
machkhan command + I doesnt work
Wanted to log in a second ago but couldn't.... Spent like $200 by now buying various sc2 accounts/expansions....
Won't be buying another Blizzard product again.
My problem is that it wont load im at the Battle. Net screen trying to login to the game but the login button wont load. But when it does it just stays at the loading screen please help
More help: BLZBNTBNA00000A8D (1007)
That's what it says

Join the Conversation

Return to Forum