Single player campaign bug on mac ?

Mac Technical Support
Just a few moments ago, I started playing the single player campaign and got up to the "lava mission" in which you had to mine a certain amount of minerals in a placed filled with lava and infested by zergs.

I successfully finished the mission, but when i click next on the mission briefing screen at the end, the whole campaign restarts with the cinematic of the beginning...

I tried restarting the game, re-doing the mission (and also tried a different mission), but then i was unable to train any units. I can move / select units but cannot create any units...

When I clicked on abort mission, the cinematic of the beginning plays

I was part of the beta tester of SC2 and everything worked fine on low settings. Therefore I don't think this issue has anything to do with my macbook's specs.

mem card : NVIDIA GeForce 9400M, 2.13 GHz Intel Core 2 Duo Processor, 2 Gb memory

Some help will be very appreciated

Join the Conversation

Return to Forum