Eternally circling...

Mac Technical Support
So, after completing the mission involving taking over the three transmitters (I forgot the planet name), it was taking too long to return back to the ship (it wasn't frozen per se but it was just sitting waiting) so I terminated SC II (cmd-opt-esc). Now, when I launch SC II, all I get is a picture of a ringed planet, some music and a cursor that moves but it just sits there and I can't get to the main log in screen. Any ideas?

This is with 10.6.4 running on a 4-core Mac Pro with an ATI X1900.
How long have you been waiting for the login screen? On my Mac sometimes I have to wait up to a minute for the login screen to show up.

Alternatively, try opening up the pause screen with F10 and seeing if it will show up.
I've waited for as long as five minutes before my patience wears out and I give up. The only thing that F10 does for me is mute the sound. I've tried using the F10 key in combination with all of the various modifier keys to no effect.
Try going into the campaign editor and running an empty map (it's the last button on the icon bar). If all goes well, it should give you instant victory. Press "Score Screen" and then hopefully the login screen will appear.

EDIT: Found this tidbit in the "known issues" sticky:

  • No user interface/menus

    • When you log into the game you will see the spaceship, but there is no place to enter your information.Rebooting your system will resolve this issue.
    Thanks, that turned out to it. I had tried logging out and then back it but that wasn't sufficient I gather. I'm guessing that it's related to available graphics RAM and not having enough to be able to draw the UI elements.

    Thanks again.

    Join the Conversation

    Return to Forum