SC2 and Comodo Firewall

Technical Support
So after patching to 1.3.3 today and starting SC2 I get a black screen on startup followed quickly by an error with the exception 0x0080a8a5. I use the internet security/firewall program Comodo, all sc2 subdirectories and files were added as trusted files, it was set into game mode, and both the firewall and system defense was set to disabled and I still got the error/crash.

After ONLY uninstalling Comodo and restarting my computer SC2 then worked perfectly, without even reinstalling SC2 or use of the repair.exe file.

I can only take this to mean that there is some conflict between the two programs. Before the patch I was able to have both running no problem at all, even with the firewall/defense active it worked fine as long as it was in the trusted list. So somehow or another the process of patching SC2 makes Comodo stop its ability to startup and then reinstalling Comodo gets everything working again.

Considering how common of a firewall Comodo is for windows users it would be nice if this was fixed but until then simply reinstalling Comodo and re-adding all the trusted files is a decent work-around.
Comodo should be giving you an alert about a shellcode injection if you quickly alt-tab and fix your screen resolution (right click on desktop-> properties).

*ALL* you have to do to fix this problem is tell comodo to skip this application in the future.
That's it.
OMG - I MUST try this. I use Comodo and had the same black screen crashing problem that you just described on BOTH my laptop (ATI HD4250) and my desktop (ATI HD5770). I will try this fix and get back to you as to whether it works.

By the way: things that DID NOT fix my problem include: complete uninstallation and reinstallation of SC2, auto-patcher, manual patching (couldn't get it to apply patch manually), repairing it using SC2 repair, and doing all of the above uninstall/reinstall in absence of an antivirus or firewall including windows firewall.

I will let you know if this fix works for me. Thanks for posting.
Uninstalled Comodo x64 and installed Outpost Security Suite x64 with a free key. SC2 works now on my laptop. Will let you know if this solution works for my desktop also.
Solution also works on my desktop. Still having issues with getting dropped by but that's another issue.

Join the Conversation

Return to Forum