Fullscreen on second monitor?

Mac Technical Support
I have a second monitor connected to my macbook pro that I would like to use full screen for playing starcraft. I can drag starcraft in windowed mode over to it, but when i go into fullscreen mode, it automatically switches to my laptop's screen. Is there any way to allow me to have it be fullscreen on my secondary monitor? I would do fullscreen windowed on it but theres no option to lock the cursor in the window for macs at the moment
don't know if this will work on a mac, but i do this on my pc

When i started my game, it starts window(fullscreen) on my primary monitor.

But i want to play on my secondary monitor.

So i go to option, change it to 'window' mode.

I can then drag the window to the secondary monitor. Go back to options and change it back to window(fullscreen)

and the game shows up on seconday screen fullscreen.
Did a bit of research on this, and With Stgarcraft II on a Mac, you can only play on the Primary screen of the OS (i.e. where the menu bar appears on the OS screen). You can change this in your System Preferences>Displays.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Small talk. Small talk... Flies. Peanuts. Dimes. Oh, and sweaters. They get muy, muy small in the wash.
ahh thank you!
Go to  > System Preferences... > (Hardware) Displays

Then in the "Arrangement" tab you move the white bar over to your other desired display to make it your primary display.

I found that out here...
http://osxdaily.com/2010/04/27/set-the-primary-display-mac/
How do I run it on my big monitor and have my MacBook be able to look up things/ chat on discord?

Join the Conversation

Return to Forum