High Latency/Ping after Playing SC2

Mac Technical Support
So, lately I've been having a high latency, and I would just assume my internet was doing poorly, shutdown SC2, and hope to play later. It never seems to get better though. I go to play one game of SC2, and at the beginning of the game I have no latency. However, as the game progresses, my latency goes up and up till it's almost unplayable. I did some testing after the game, and my ping was 500ms to a server less than 100 miles away. Funnily enough though, my ping returns to normal after I stop playing for like 10 minutes. Returning back to near 20ms to the same server, and like 100ms across the country (VA to CA). I'm not 100% sure SC2 is causing it, or even what in SC2 is causing it. I'm just posting here because I have no idea what else to do. So, any help would be greatly appreciated.
:(

Other than testing the ping, have you tried seeing if powercycling your network devices help at all? Always good to start at the basics.

Powercycle your network devices.
    1. Unplug your modem and router (if you have one.)
    2. Let them set for 30-60 seconds.
    3. Plug them back in modem first, then the router.
    4. Test


Also, does this happen only at certain times of the day/week?
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Mac Blue will make you JUMP JUMP
Tony Mac will make you JUMP JUMP
Blue posts will make you JUMP JUMP
This has been happening to me lately as my ping goes up to 15000~. I tried to powercycle the devices but it did not work. Did the OP find a fix for this?
Hey PieDealer, the OP posted this 2 years ago ;)

Can you run a trace route, and post it in a new thread?

________________________________________________
Rate me! https://www.surveymonkey.com/s/Velnrak

Join the Conversation

Return to Forum