Unable to download an authentication module.

Mac Technical Support
I opened sc2 last night as usual but a message pop up says"Unable to download an authentication module. Please try again later." i searched in the forums tried to delete the billiard folder in share folder. didn't work. after that i reinstalled the game, but this problem remains.

Using MAC Book Pro. MAC os x Ver. 10.7.1.
Processor 2.3GHz Intel Core i7
Memory 8GB 1333MHz DDR3
Hi Ryo,

This is often the result of corruption in the Blizzard in Users/Shared. There are 2 folders in there, Blizzard & Blizzard Entertainment. Did you remove the "Blizzard" folder only? I just want to ensure that.

Also, make sure your OS X firewall is allowing SC2 as an exception. Alternatively, you can try disabling your firewall to see if this help. I would also recommend doing this for any security software as well.

Lastly, you may want to try a permissions repair, to ensure this isn't an issue due to bad permissions.
Repair Permissions via Disk Utility
    1. Navigate to /Applications/Utilities/ and open Disk Utility
    2. Select the hard drive the game is installed on
    3. Select the First Aid option
    4. Click on the Repair Disk Permissions button

Resetting permissions on the Starcraft II folder
    1. Select the Starcraft II folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items

Then run a repair from the repair tool located in /Applications/Starcraft II/Support.

Let me know if this helps.
Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
Realize that life is a school and you are here to learn. Problems are simply part of the curriculum that appear and fade away like algebra class but the lessons you learn will last a lifetime.

Back in my day, I had to teleport to and from school in the snow, uphill, both dimensions!
I was not able to solve this problem by looking for anything found on forum batle net a guy who had done the same and what do probrema he said and it worked for me sorry that I can not remember his name but the credit and all who try it going to work down here let the procedure sorry my english

One. Download Hotspot Shield (search in google)
2nd. Install and run it
3rd. Start SC2 (Wings of Liberty)
4th. If the issue was authentication module error it would automatically be resolved now.
5th. If you could not download maps before (ladder or custom games), you can download it now.
6th. After all this is done, quit SC2, uninstall hotspot shield and start SC2 Normally like before.

This thread is for Those Who are still waiting to play the game and dont know this fix. To All Those who know, good for you: D
His name was Harbinger
Locking this thread.

This is a very old thread that isn't relating to the current DNS issue. If you still have issues please create a new thread. Thanks!

Join the Conversation

Return to Forum