Download not authenticated - What I've found

Technical Support
Hey guys

I'm trying to download the game client, and I login bnet, download the game client, fire it up and no problem it starts downloading...

After a while, suddenly it stops and says "Download not authorized" or something like it.

If I run the same exe, it goes to the error.

I have to RELOGIN to BNET, download the downloader again and fire it up...

Mind you, the downloader does this after 30 minutes or so... coincidentally, just as bnet (web browser) logs me out of the website for inactivity, and I have to relogin.

What gives? If I don't login again to bnet over web browser the download will fail, and it stops right after the cookie expires. Why is this connection? Huge bug, I can't possibly download 6.99GB of data in 30 minutes, so I've had to relogin and restart the download 5 times now and counting.
Do you have "Keep me logged in" checked? There ought to be a way to keep this from happening.

Either way; the downloader isn't supposed to do this so there is likely another problem thats causing it.

1. Are you running the download as an administrator\on an administrator account?
2. Have you tried disabling your anti-virus\firewall?
3. Try checking your LAN settings:
There's no keep me logged :(

It's running as administrator.
Virus/Firewall disabled.
LAN Settings checked.

I can tell almost by the minute when the download is going to fail, because, like I said, the website logs me off. When I see bnet logs me off the download stops and says "This download is not authenticated".

I have to relogin, redownload the downloader and start it up again.

Join the Conversation

Return to Forum