SC2 sound problems with speakers/headphones

Technical Support
I am having a similar issue.... When I run Starcraft 2 using the default device (Independant speakers) is plays through the laptop's built in speakers (even when closed). Where as the same device works normally through other games like Blizzard's own World of Warcraft. This is highly irritating.

If anyone has a solution for this problem I would be grateful.
I am having a similar issue.... When I run Starcraft 2 using the default device (Independant speakers) is plays through the laptop's built in speakers (even when closed). Where as the same device works normally through other games like Blizzard's own World of Warcraft. This is highly irritating.

If anyone has a solution for this problem I would be grateful.



there is a solution. go back and read the entire thread..
Omg monkeys suggestion works.

DO WHAT MONKEY SAID =) Ty Ty Monkey
Search 'manage audio devices'

Disable Communications Headphones.


This man is a genius. IT WORKED.
You sir are the best, thanks for making my day better.
I don't get an option to disable communications headphones when I go there. It just lets me decide how much to reduce the volume of other programs when it detects communication, which does nothing anyway. Now this is really pissing me off.
Ok, so Baron I am guessing that you have you headphones set as the default communications device, simply change that to your stereo mixer and it seems to fix the problem.
If you do it monkeys way, it disables the headphone entirely and you would have to enable it everytime you plug in headphones. Another way to do it is to go to the properties of your default communications device, and then advanced, then untick the box that says "
allow applications to take exclusive control over this device." Skype updates usually change this option to ticked so just untick the box and it should work right + when you plug in a headset it will automatically go to your headset settings.
Wow I had the exact same problem. Monkeys solution works :D :D :D
monkey lord fixed for me too ;)
hey, I tried monkey lords solution, and I got the music to play into my headphones again, but when I tried the starcraft sounds are mute,
Search 'manage audio devices'

Disable Communications Headphones.


This works. Kudos.
Search 'manage audio devices'

Disable Communications Headphones.

This is the only thing that worked! I didn"t even think of it.. God Damn Beats By Dr Dre!!!
I also have an HP dv6
Search 'manage audio devices'

Disable Communications Headphones.

worked! thanks amil to Monkeylord
monkeylord is awesome
The disable communications may work, but ALSO check in your sound setup, that the game itself is not MUTED.

While SC2 is running, alt-tab out, Go to your sound Icon, right click, choose "volume control options", on the "device" section select "Speakers and headphones" and it will pop up all programs that are using sound...that's where I found that SC ONLY was MUTED...everything was not and worked fine.

Using an HP, I also disabled the "IDT Sound" manager using the "msconfig" command from the run menu. This may no be necessary, but the daggon thing is just unnecessary and confusing things.

NOW the question on how it got muted in the first $%^ing place...

SUPPORT THE CORPS!
Yea thanks a million. Worked for me.
ive been having different problems when i try to listen to music while playing but when i log in the music stops so i cant even listen unless i alt tab out
Thanks Monkeylord!

Join the Conversation

Return to Forum