SC2 sound problems with speakers/headphones

Technical Support
FOR THOSE WHO CANT HEAR A SOUND IN THERE HEADPHONES BUT THERE'S A SOUND IN THE INTERNAL SPEAKERS BEST WAY TO FIX IT IS LAUNCH/OPEN SC2 AND PRESS ALT+TAB, GO TO WINDOWS SCREEN AND CLICK YOUR SPEAKER ICON SHOULD BE AT THE RIGHT BOTTOM PART OF YOUR SCREEN/ CLOSE TO YOUR TIME AND DATE.. AFTER YOU'VE OPEN IT THERE SHOULD BE TWO SOUND SETTINGS OPEN... 1 IS YOUR EXTERNAL HEADPHONE AND 1 IS YOUR COMPUTER SPEAKER SETTING.. SO (MUTE YOUR EXTERNAL HEADPHONE) AND RETURN BACK TO YOUR GAME LAUNCH/OPEN...AND YOU SHOULD BE GOOD.
Found this thread over Google with the same problem. Monkey's miracle fix didn't work, but setting speakers and headphones as the default device did.
Search 'manage audio devices'

Disable Communications Headphones.


sorry for necro all, but i just had to give dude props, this is the first time ive found a good solution!
I am having the same problem...
i don't have the option to do what monkey said...
this is pissing me off aswell
Thank you guys so much! I've been having this problem and myself, my roommate, and my roommate's friend couldn't figure it out! Thank you again!

All I did was set my speakers to default, and then disabled my headphones just for good measure :)
Thank you so much man.
i disabled my speakers, how do i get them back, they arent there anyomore plz help :(
Thank you so much!
Nice one Monkeylord!!
THANKYOU BLIZZARD!!!

i have looked for a way to fix my headphones and you are the only one that was able to help me <3
thanks so much monkeylord ^^
MONKEY I LOVE YOU HOMIE. That seriously was bothering me for like 10 years. OMG I wish I found this earlier
my computer doesn't have speakers so when i have star craft 2 open i can't hear anything
Monkeylord you are my savior. You name shall be sung for all future generations of starcraft players
I fixed this issue tonight. I know it's an old thread, but still relevant today. Simply disable your speakers if you have headphones plugged in that register as communication headphones. Good to go. Sound from your browsers or music players SHOULD now come through your headphones! I hope this works for all of you.

Details: Open Control Panel and find the Sound subfolder/section.
Go to Playback tab and Right click your speakers.
Disable them.
Done!
GL HF
thanks monkeylord
Got a sound issue too, only in SC2. I hear a prrrtt pprr prrr prrrrrrt sound glitch all the time, ive tried to put all my driver up to date, still have the sound issue... any clue?

Join the Conversation

Return to Forum