SAVE FAILED! YES!

Technical Support
I've tried looking this up, i saw a few on the fowums, non of which offered a solutions. On campaign mode it always says "SAVE FAILED" i downloaded my copy of SC2 yesterday from Blizz, if that makes a diference.
The latest patch that was released (1.0.2) might be what's screwing around with your save game files.
any possible solution?
Unfortunately, not that I know of, lol. Blizzard hasn't really been helpful in helping us out with issues involving the latest patch, mainly a bunch of useless information for the most part.
bump! i'm getting pissed. Your f'n game does not work. i wanna play campaign and cant save. why wont blizz adress the issue or put it under support or something. Thanks for your usual crappy support blizz. Glad i wasted money on your broke game.
I'll bump this till a blue gives an answer.
I have this same exact issue. I can't continue the campaign and fully expect to have to start over. The game forgot I beat one of the most annoying missions ever, and I'm not going to go through that again until I know this is fixed.
I thought this would fix it, but it didn't work for me. Go to My Documents/Starcraft II. There's a few folders in there with SC2Save files.

Look at ../Saves/Campaign and delete (or move) all save games from here except for your last manual save.

Next, delete (or move) everything from the ../Saves/Unsaved folder.

Lastly, copy your last manual save (from ../Saves/Campaign) and paste it in ../Saves/

Delete "LiberyCampaignSave.SC2Save" and rename your last manual save to that.

While it did update my "last mission played" on the single player menu, it did not fix the problem :( I started a mission and did not have the tech that I had purchased in the armory.
This is still a problem, get off your ass and give a solution Blizz, or refund me.
I copied over a friend's save game files and tried it... I bought some stuff in the armory and picked a mission. No upgrades. I went back to the ship and it loaded a game file that did not exist on my PC.

Clearly Blizzard's syncing of save game files is screwed up and no matter what I do on my PC, I'll never be able to continue until things are fixed on Blizzard's end.
least they could do is come on here and state that a problem exists.
this is still an issue, need an answer.
We're not alone - http://eu.battle.net/sc2/en/forum/topic/91609608?page=1
I fail to see the Support in this Technical Support forum. Blizz just sold me an item, then gave me the middle finger when i said it didnt work.
I haven't seen that problem before. Have you tried running SC2 as administrator? Might be worth a shot.
I haven't seen that problem before. Have you tried running SC2 as administrator? Might be worth a shot.


I owe you... that worked.

The odd thing is that everything was working fine for the first week, but it started acting up after the patch.

Thanks!
I owe you... that worked.

The odd thing is that everything was working fine for the first week, but it started acting up after the patch.

Thanks!


Glad it worked out.
I ran SC2 in admin mode, no new results. Still says SAVE FAILED! i really want to complain about this, i already want my money back. It not the fact that it's broke that makes me most angry, its the fact blizz could give a crap, whats one customer right? money in the bank for them.
Bump
The save files are written to your Documents\StarCraft II folder. You shouldn't need to run it as an admin for write access there. Can you try renaming the StarCraft II folder in your Documents folder to something else and see if you can start the game and save stuff?

Join the Conversation

Return to Forum