Offline mode - "starter edition"?

Mac Technical Support
Hey guys,

So I'm currently behind a firewall that blocks all of Blizzard's various game servers. Sucks. I'm trying to play starcraft 2 using the offline mode, but when I try to it says the starter edition does not support this. Problem is, I don't have the starter edition, I have the full copy of the game.

This has happened to me in the past but I've just waited for whatever was wrong with my internet to be fixed and then it was nbd. Unfortunately no amount of waiting is going to fix this firewall and I'd like to tool around against computers and/or work on the campaign/challenges.

Is this something that is easily fixed? I did some googling and found nothing but people complaining /extra/ hard (sts), it was pretty ridiculous.

Anyway, thanks for your time.
This is probably due to SC2 needing to reach our servers for authentication. SC2 must reach our serves and fully authorize every 30 days to be able to play normally.

If you've recently installed SC2, it sounds like it has not been logged into via to authorize. This is probably why it's still thinking it's a starter edition.
hello, i am having a similar issue. i haven't played SC2 in some time, and i reinstalled a few days ago to go through the campaign again (just pwnd the original and brood war again, so fun!!). i had purchased the full game back in 2010 when it released, but didn't feel like looking around for the install disc so i downloaded the game client from your servers, installed and patched and logged on. when i signed in, however, i received a message saying that i have the starter addition and requested if i would like to upgrade to the full version.

on my bnet account game management page it says i have "SCII-1, North America", "SCII-1 (starter edition) EU, Europe", SCII-1 PTR and SCII-2 PTR. i don't know why i can't access the full game and why it asks if i want to upgrade to the full retail when i already have it activated on my account?
04/26/2012 05:52 PMPosted by JizzyFuknJay
on my bnet account game management page it says i have "SCII-1, North America", "SCII-1 (starter edition) EU, Europe", SCII-1 PTR and SCII-2 PTR.

I'm thinking it's due to the EU starter edition on the account. You will need to contact customer service to get the account removed. After that I would suggest fully uninstalling SC2 and reinstalling and see if the error appears.
Just bought the full version of the game and it will not upgrade to the full version I've downloaded it many time to no avail. What do I need to do in order get this game started?
That is strange. Can you do me a favor and check these things?

1. Make sure your system clock is correct.
2. Navigate to /Applications/StarCraft II/Mods/Core.SC2Mod and see if you see some files that begin with enUS
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

This is small step for me, but big step for humanity. Or something like that...
Make sure the email address is the same one you used when you first installed SC2 and set up your battlenet account. I called customer support b/c I had the same issue and he said that the standard version of the game was tied to a different email address.
He was able to move the standard version over to my current battlenet account email and the issue was resolved!
god i hate dlc...

should of just torrented the cracked copy of the damn thing...

(!@#$ i own the game this is just stupid)
Whoa Whoa Whoa, so.. I have a full version of the game, been playing since around release of it.. but if I don't log in every 30days I become completely locked out????

I smell a lawsuit coming blizz's way.
No, you're not locked out. You can log in again and access offline mode for 30 days. I think the best way to think of it is that offline mode is good for 30 days form your last login.

You can take a 2 month break from SC2 and come back and login, which then renews it. This is how SC2 offline mode worked since launch.
i bought the sea last year and i didn't play for like 1 week and then 2 days ago i play version and it worked i have all my achievements but i suddenly have the starter edition cause i dont know if it is offline mode
This is something that is being investigated. Thanks for the report.
Same issue here. I launched the game ok a couple days ago, now after the patch, I'm at the starter edition. My account says I have the standard edition license.
I played 2 days ago, now I log in and it is saying I have the starter edition... Under account management I not only have the full game, but I also have pre-purchased HoTS.
Hey all I had the same problem I changed my password and it fixed it, maybe that will work for you guys too.
If you're still having this issue, try what Jimmy suggested. This issue should be resolved, but the password reset does force update your server side cache if it is still stuck.
I had the same issue, just changed my password and solved the problem.
01/24/2013 11:19 AMPosted by Drisc
I had the same issue, just changed my password and solved the problem.

password change worked for me too

I just tried again without changing my password, and I'm back to the full game. Thanks for taking care of the issue!

Join the Conversation

Return to Forum