StarCraft II - Patch 1.5 Mac OS X 10.5 No Longer Supported

Mac Technical Support
Prev 1 5 6 7 8 Next
Where do I request a refund formally?
Support/ Ticket. Request the reason you want a refund. You won't get it. But it will be documented.
I think it's great that they are improving the game and graphics and !@#$.. and that new expansion that is coming out looks dope. But its bull %^-* we have to pay extra and update our own computers for this. If anything, they should include a software upgrade in the !@#$ing patch. At a store it is about 20 bucks. But if they just charged us a compromise of like 10 and upgraded our software for us it would be fair considering the gameplay is improving.
Not good enough Omega.

The solution is not to make it so we can't play at all. The solution is to stop allowing us to update the game.

I must have missed the post where it states people running OSX 10.5 won't be able to run the game at all. I read it as 'people running 10.5 won't be able to patch the game but will still be able to play offline & singleplayer.'

Here's that quote. :)

06/08/2012 11:46 AMPosted by Machkhan
Mac OS X 10.5 will no longer be supported, and you will no longer be able to patch the game.
I am very upset with the way this is being handled by Blizzard, and I do hope that something is done about the downloader issue, and a formal apology is given by the company.
08/01/2012 10:28 AMPosted by Entolophant
I've already contacted a couple lawyers, and they can't wait to take this one. Blizzard must make how much a year. Yeah I can't wait for this...


Wait to get shot down?
->system requirements are subject to change<-
-Mac no longer services this OS why should they-
-is windows me suppoerted? or 97? i have some PC with those OSs on them-
-Im sorry that Apple cahrges for Os updates not new OSs but thats not blizzards fault-
-You can boot windows Os onto a mac comp and windows 7/vista are cheap
-Macs consist of how much of the population of sc2 gamers?-
-why dont they make gamecube or N64 or PS2 games anymore?-

I get it your mad but hey Oblivion GotY edition didnt work on either of my PCs one running Xp hte other vista yet both easily met the requirements and only got it to run on my W7 soon after i got it welcome to technology in with the new out with hte old often in very sudden and dramatic results
08/04/2012 05:33 PMPosted by rearti
I've already contacted a couple lawyers, and they can't wait to take this one. Blizzard must make how much a year. Yeah I can't wait for this...


Wait to get shot down?
->system requirements are subject to change<-
-Mac no longer services this OS why should they-
-is windows me suppoerted? or 97? i have some PC with those OSs on them-
-Im sorry that Apple cahrges for Os updates not new OSs but thats not blizzards fault-
-You can boot windows Os onto a mac comp and windows 7/vista are cheap
-Macs consist of how much of the population of sc2 gamers?-
-why dont they make gamecube or N64 or PS2 games anymore?-

I get it your mad but hey Oblivion GotY edition didnt work on either of my PCs one running Xp hte other vista yet both easily met the requirements and only got it to run on my W7 soon after i got it welcome to technology in with the new out with hte old often in very sudden and dramatic results


1. It's true, it does say that on the box, but we didn't expect Blizzard to actually do it once we bought the game.
2. That question is irrelevant. Neither of those systems were current when SC2 was in development/released. 10.5.8 was current (or at least close to current) when SC2 was released, so changing the requirements now is just a *@!* move that shows Blizzard doesn't give a !@#$ about their customers, only their money piles.
3. Blizzard could've at least investigated the ability of Mac users to switch to 10.6, and then could have made a smarter decision on this matter.
4. This is a valid point.
5. This is just a *@!* question. Are you a racist as well?
6. That question is irrelevant as well. When the Xbox 360 came out, you could still play Xbox games on Xbox. It wasn't like "you need Xbox 360 now to play a game that you could play on Xbox as well".

Blizzard doesn't care about their customers. They just leave us out in the cold. This issue will keep coming up when 10.6.8 is killed off, and 10.7, and so on. Blizzard is really asking for it with this new Mac support policy.
I have a running 6 month old imac with 10.7 software, however, when I attempt to open the SC2 launcher, I receive an error saying "internal error" with the only option to close the browser. I tried reinstalling the game from the disc 30 minutes ago, hoping it was just a corrupted file, but with no luck. The weird part was when I finished installing, it gives the option to "play" from the download screen. I clicked that and the game ran perfectly. I then closed the game and attempted reopening the launcher, but received the same error. I am assuming this is just a launcher malfunction, but I have no knowledge on this field so my guess is as good as any. Assistance would be welcomed.
Notice your not getting any responses from Blizzard in this thread, should tell you something.
I feel for all of you here, and I run 10.6.8. Blizzard is handling this wrong and is stealing what you did pay for. Reasons like this and the fact that they don't address this issue makes me feel animosity towards Blizzard. If, for example, they stopped Windows XP support and then removed support for that operating system, Blizzard would lose a few thousands, if not millions of customers, and they can't afford that. But, because the Mac OS X operating system has less users than windows and has a smaller fraction of them on 10.5 because its an older operating system, they feel that they can afford to remove everyone and anyone who had once bought Starcraft II on Mac OS X 10.5. Blizzard needs to address this issue to prove that they care for their customers and show that the Mac OS X community is important to them.
wtf i cant play.what happend?why am i looking at this launcher for an hr and nothing happend.
i have osx 10.7.4 and my game wont run. blizzard is just screwing mac users over for no reason. ill just switch to pc gaming then.
If you're not on 10.5 and experience issues starting the game, please create a new thread to help resolve the issue.
This is so dumb.... I can't believe a game I got many people to buy, and you stab me in the back. Thnx for using me as a marketing tool and throwing me away like trash.... I have the snow disc.... My ALMIGHTY SUPER DRIVE doesnt work... Sounds like a flippin conspiracy to me.... You guys are wrong. No need for updates. Played for 2 years, and guess what? NO PROBLEMS! You want an update.... Guess what? PROBLEMS. GTH
08/13/2012 09:36 PMPosted by Twigginator
This is so dumb.... I can't believe a game I got many people to buy, and you stab me in the back. Thnx for using me as a marketing tool and throwing me away like trash.... I have the snow disc.... My ALMIGHTY SUPER DRIVE doesnt work... Sounds like a flippin conspiracy to me.... You guys are wrong. No need for updates. Played for 2 years, and guess what? NO PROBLEMS! You want an update.... Guess what? PROBLEMS. GTH

Use an external DVD drive then.
08/12/2012 08:33 PMPosted by CryoGaia
i have osx 10.7.4 and my game wont run. blizzard is just screwing mac users over for no reason. ill just switch to pc gaming then.
Yep, they just love screwing Mac users just for the fun of it... /sarcasm
I know little to nothing about mac software but I am running 10.5.8 and I cannot get past the launch window. I know they are saying to buy 10.6 for thirty bucks or whatever but can I just purchase osx lion for twenty of the ap. store?
08/15/2012 12:41 PMPosted by Mateo
I know little to nothing about mac software but I am running 10.5.8 and I cannot get past the launch window. I know they are saying to buy 10.6 for thirty bucks or whatever but can I just purchase osx lion for twenty of the ap. store?


To get to Lion you first need to get 10.6, which requires you to call apple and pay 30 dollars for that, and then you can get Lion (i think its 10.7) which is an additional 20.

So you can't skip versions. The idiots at Blizzard didn't take this into account when they decided on this terrible support policy.

Join the Conversation

Return to Forum