Starcraft 1 CD Key Issue

Off Topic Dicussion
I recently purchased a retail copy of StarCraft 1 (one). It installed fine with the old 13-digit cd key which came with my copy of the game. However, this key only worked during installation. I was able to start up the game and play single player fine with no hassle. But multiplayer is where the problem started. I selected as my connection method, being on broadband internet. It tried to connect me to the multiplayer server but hen gave me an error saying "The CD Key you provided was meant to be used for another product...please reinstall with the right CD Key." I'm stumped as this is the only CD key I have. The disk was a little old so I thought that it could be messing with some corrupted files, so I decided to use a digital download. However, when I entered my 13-digit key into the "Add Game" menu of account management, it gave me the "Code cannot be claimed" error. I looked around the FAQ and the support database of this website. They said that legacy games such as Starcraft 1, Diablo II, etc. needed their CD-key converted from the old 13 digit to the new 26 digit alphanumeric format. They also said that I would be prompted to create a "Classic" account when I started multiplayer in the legacy games. This did not happen in my case. The site didn't take my code and didn't convert it either. Still trying to figure out what must be wrong, I ran the program under compatibility mode and as administrator and patched it to the latest version. None of this helped with my issue. Please provide assistance on this, I would really appreciate it as I am an SC2 fan and wanted to try out its older sibling. I understand it is a really old game and I didn't expect it to run without hiccups. The store would not take it back unfortunately, even after explaining my issue. Any help would be appreciated! I also sent this as a ticket to Blizzard, but decided to put it on the forum as well to see if anyone else had the same issue. Any help would be great. Also, I tried posting this in the SC1 forums, but it required a CD key to login and it obviously didn't work.
Thanks much!
I had a similar problem when I tried to install Starcraft that I purchased years ago and ran into problems with the old 13 digit key provided. Maybe the procedure that I used will help you.
1. I logged into my account.
2. I clicked "Add a Game" under account column at the bottom of the page.
3. I used the old 13 digit code to register my game with
4. I went to my games list an and found Starcraft I listed there.
5. I downloaded the game from
6. I retrieved a new 26 digit cd key from the same location where I executed the downloaded.
7. I installed the download using the new cd retrieved from the site.
The game installed and so far is running fine.
Hope this helps.
You can always just use a cd key changer. Just google it and you should find one. It worked for me when I lost my cd key.

Join the Conversation

Return to Forum