'An error occurred starting StarCraft II.'

Technical Support
When I try to start up StarCraft II, i get an error message stating, "An error occurred starting StarCraft II. Please try again later." This has been going on for about a week now, and it's gotten to the point where I can't stand it. I've tried everything obvious (i.e. re-installation, running as administrator), so if anyone has been able to fix this problem in the past, it would be a major help if you told me
I'm having the same issue. I just got a new computer and have been able to install and play every other game that I've tried to, including a Blizzard title, Diablo 3.

I've tried installing from the disc and from bnet. I made sure my drivers are up to date. I've run as administrator and searched all over the internet looking for a solution and none of them have worked. I don't understand how there can be this glaring of an issue (just google "An error occurred starting StarCraft" and you will see that this is a fairly common problem) and still no clear solution. This, combined with the catastrophe that was Diablo 3 is really starting to make me feel differently about Blizzard.

Another thing to note is that after trying to open the game (and seemingly nothing happens) if I open the task manager I can see that SC2.exe and SC2switcher.exe are both running under the processes tab. I don't know if this means anything or not, but I thought I should mention it.

If anyone knows of a way to fix this, please let me know.
I am having the same problem on my machine as well. Tried re-installing and everything but no dice.

Specs
windows 7 Home Premium
Intel i7-3770K
Radeon HD6870
6GB DDR3 RAM
Dont know what you would need to know otehr than that but there you go
same issue. figure it out bliz!
Same issue just happened today, I am unable to play now.
Same issue just happened today, I am unable to play now.
Same issue here had it happen a week ago still no way to fix it
I fixed it then

move sc2 game folder from Program files x86

to

Program files....

just copy paste, delete the x86 version and it all worked for me
I have the same problem except the message only appears after I have to close the process SC2.exe because nothing happens when I click play.
I am currently having the same problem that Jadis has happened. Has anything been figured out? I have re-installed from cd and client dl. Opened ports and made sure my firewalls allow it to go through. Even moved from file x86 to regular program files. I played it on my laptop previously with no problem..
And as well, I just recently followed the steps to a T from Kelphe (http://us.battle.net/sc2/en/forum/topic/6758457168), with the same end result. Which is, starting up the execute file and nothing loading. Then having to go into task manager to close the program and being told upon end tasking it, that "An error occured starting Starcraft II. Please Try again." Help would be greatly appreciated as I've been pulling my hair out trying to figure out what's going on. Thank you.
i've been dealing with this issue for weeks. i am pulling hairs out of my head to fix it
Was having same problem, Mpower's solution worked for me thx dude.
This solution worked for me!

I'm running Windows 7 Ultimate 64 bit edition and Collector's Edition Heart of the Swarm. I was playing last night with friends in a 4v4 and I was getting about 1 FPS. So I quit out, and logged off, and was unable to get the game to start, the loader worked, and when I hit play it would say " An error occurred starting StarCraft 2. Please try again." This was driving me nuts. I tried deleting caches, etc. But copy and pasting from from the x86 program folder to the equivalent regular program folder was all that was needed. No further patching, no windows patching, no driver file updates, no restart. It just worked right off the bat.

The only thing I can think of is that maybe the changed the loader to be x64 bit which wouldn't work accurately from the x86 program files (due to it not being 32 bit). One of my housemates had this problem with World of Warcraft a few months ago.
Moving the Starcraft 2 folder the regular Program files worked for me. Thanks Mpower! :D
Mpower ty u dude did it worked (note: window firewall tryed to block it too, granted all access)
note also that the shortcut will refter to the 86x and if used will cause problem and say achievements is turn off
Yup I had the error message pop up, and I tried the suggestion of copying the game file to a new folder and it worked like a charm. I tried everything I could think of before trying that one.
Its 2016 with patch 3.1.4.41219
This issue still happens on Windows 10 64 Pro.
Moving the game files to Program folder has no effect.

Join the Conversation

Return to Forum