Game crashes on startup after 1.5 patch.

Mac Technical Support
i have a 27" mid 2011 iMac running on 10.8 Mountain Lion with a 3.1 ghz i5 and the 1 gigabyte 6970M graphics card, and before the patch i was able to play StarCraft 2 just fine, however with the new patch the game starts, shows the loading screen just before it goes to the menu like always (at a much lower resolution than i normally play at at that) and then crashes shortly thereafter, sometimes screwing up my desktop resolution as well because of the crash and forcing me to kill finder so that my icons go back to where they are supposed to be and so that i can click on them again. Id like to play SC2 >_> any help with the crashing?
i dont think mountain lion is the problem as i have been playing the past few days perfectly fine, and was playing last night before the patch no problem, the problems began after i downloaded the new patch, i also let it fully patch before starting the game and still have issues.

EDIT : Tried restarting, now im just getting the "an internal error has occurred" thing and the game isnt launching at all... -__-

EDIT 2 : There is now a possible solution for this problem
Typhoid
My ticket has been answered, it appears that a program I used to use left a plugin on my computer that interfered with Starcraft. The program was Hear, so if any of you are using it try uninstalling it.

As for removing the plugin if you have already removed the program go to
/Library/Audio/Plug-Ins/HAL/Hear.plugin
and drag the hear.plugin to the trash

So far everything works fine, although like others have stated my computer definitely runs warmer when playing now
#13
58 minutes ago
Like
REPLY
QUOTE


It appears that the application Hear is interfering with SC2, this fix has worked for me and typhoid, so if you have Hear installed try the above steps and report back, you have to go into the library folder in the root directory (not the one in the users folder) to find the pluggin

If you dont have Hear installed, its possible other plugins could be interfering as well, so play around with them a bit (dont do anything you cant easily reverse though) and report back if you find any other applications causing SC2 to crash.
Okay so i took a look in console and this is what it spits out when i try to open SC2

7/31/12 8:12:23.000 PM kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=2577[Blizzard Launche] clearing CS_VALID
7/31/12 8:12:29.226 PM Agent[2571]: objc[2571]: Object 0x1977f20 of class __NSCFData autoreleased with no pool in place - just leaking - break on objc_autoreleaseNoPool() to debug
7/31/12 8:12:40.819 PM Dock[256]: no information back from LS about running process
7/31/12 8:12:40.896 PM com.apple.launchd.peruser.501[235]: ([0x0-0x1ac1ac].com.blizzard.starcraft2[2584]) Exited with code: 1


When i launch SC2, the game loads up for a brief moment, shows the maps initializing text at the bottom, and then crashes.
this is happening to me too, identical specs
I have the same problem, after the patch I can't play on my macbook pro, I'm using Mac OS X 10.7.4.

I already tried reinstalling twice, with no positive results.

I hope this bug get fixed soon.
Same problem here. Running 10.7.4 on macbook pro. It usually crashes right as Jim Raynor's face appears.
after digging around in the error logs a bit more and based off of what i saw in console, i believe this is defiantly some form of memory allocation problem

From console :
8/2/12 10:03:53.000 PM kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=1711[Blizzard Launche] clearing CS_VALID
8/2/12 10:04:10.082 PM Agent[1705]: objc[1705]: Object 0x1e36b80 of class __NSCFData autoreleased with no pool in place - just leaking - break on objc_autoreleaseNoPool() to debug


From my error logs
Memory Usage Startup Error Current

CRT malloc
Bytes 0 0 0
Peak 0 0 0

MemAlloc
Allocated 0 4 53,901,780
Overhead 0 0 0
Header+Footer 0 0 0
# Blocks 0 0 0
Committed 0 4,194,304 61,812,736

dlmalloc Committed
mspace0 13,746,176 166,281,216 166,281,216
mspace1 4,096 4,096 4,096
mspace2 4,096 1,466,368 1,466,368
mspace3 4,096 4,096 4,096

Thread Stacks
Comitted 0 0 0
Reserved 0 0 0

Loaded Modules
Comitted + Reserved 0 0 0

Sound
Allocated 0 4,375,578 4,375,578

Resource Estimation
invalid 0 0 0
texture 0 11,405,164 31,868,872
shader pair 0 3,165,396 3,165,396
specialized shader 0 1,663,613 1,663,613
model 0 57,948 57,948
sound 0 0 0
movie 0 0 0
light 0 0 0
Total 0 16,292,121 36,755,829

Process Memory
Pagefile Usage 0 0 0
Pagefile Usage Peak 0 0 0

Working Set 0 0 0
Working Set Peak 0 0 0
Working Set Min 0 0 0
Working Set Max 0 0 0

Paged Pool 0 0 0
Paged Pool Peak 0 0 0

Nonpaged Pool 0 0 0
Nonpaged Pool Peak 0 0 0
Global Paged Pool 0 0 0
Global Nonpaged Pool 0 0 0

VirtualQuery Pages
Committed 0 0 0
Reserved 0 0 0
Free 0 0 0

Max Contigous Free 0 0 0

Committed-Private 0 0 0
Committed-Mapped 0 0 0
Committed-Image 0 0 0

Reserved-Private 0 0 0
Reserved-Mapped 0 0 0
Reserved-Image 0 0 0

Mystery Memory 0 4,277,704,215 4,199,622,075

System Memory
Physical Mem Used 2,571,788,288 2,590,945,280 2,574,249,984
Physical Mem Free 1,723,179,008 1,704,022,016 1,720,717,312
Physical Mem Total 4,294,967,296 4,294,967,296 4,294,967,296

Page File Used 2,720,210,944 2,740,858,880 2,731,077,632
Page File Free 1,843,191,808 1,822,543,872 1,832,325,120
Page File Limit 4,563,402,752 4,563,402,752 4,563,402,752

Process VM Used 941,764,608 1,209,274,368 1,296,642,048
Process VM Free 3,353,202,688 3,085,692,928 2,998,325,248
Process VM Limit 4,294,967,296 4,294,967,296 4,294,967,296


An absolutely insane amount of errors

More from the error logs, early on
====================================================================================================
StarCraft II (B22612)

Executable /Applications/StarCraft II/Versions/Base22612/SC2.app
<Parameters> -launch -uid s2_enus
LocalTime 2012-08-02 21:53:33.118
<ComputerUser>
<ComputerName> JustAnotherMac
<Version> 1.5.0.22612
<CodeBranch> branches/1.5.b
<CodeRevision> 118806
<Locale.Product> enUS
<Locale.Assets> enUS
<Locale.Data> enUS
<Inspector.ProjectId> 3
<Inspector.IssueType> Exception
<Inspector.BuildNumber> B22612 (1.5.b)
<Inspector.Branch> branches/1.5.b
<Inspector.Platform> Mac
<Inspector.Priority> 1 - Critical
<Inspector.Assignments> .Mac Team
<Inspector.Summary> Heap Corruption (ptr: 0x214C9000 214C8FF0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................ 214C9000: C8 02 28 17 00 00 00 00 00 00 00 00 14 A1 20 17 ..(........... . )
<ErrorType> Heap Corruption
<Application> SC2
====================================================================================================
<Inspector.Assertion:>

Heap Corruption
ptr: 0x214C9000
214C8FF0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
214C9000: C8 02 28 17 00 00 00 00 00 00 00 00 14 A1 20 17 ..(........... .


Pleeeeeeeease fix this soon blizzard ;_; rebooting into my bootcamp partition every time i want to play SC2 takes forever and is annoying, not to mention playing in windows throws off my game because all of the settings are different and i cant use cmd in the place of ctrl.
That's exactly what i'm suffering. Running Macbook Pro late 2011 with Mountain Lion.
I have the exact same problem, also on a late 2011 Macbook Pro running OsX 10.7.4

I've tried all the workarounds I have found in the forums including
-setting my library and application support permissions
-deleting the blizzard folder from the application support folder
-removing the battle.net file from the user>shared folder
-ensured there were no processes lingering in the activity monitor
-checked for .part files in the updates folder
-ensured that launch.db was enUS

still no luck, crashes just as Raynor's face appears and states unknown error
Anyone heard of workarounds for this issue? I'm hesitant to upgrade to OSX 10.8 as it seems this does not resolve the problem
:(
Are any mac users actually playing right now?
not entirely sure snacks, however ive put in a support ticket on this issue (which didnt get auto-responded with a diablo answer this time, hooray!) and after about a day's worth of back and forthing with no suggested solutions working the person handling my ticket said they would submit the problem to the QA team, so mabey blizz can look into this and fix it soon, i hope so atleast, i really miss playing SC2 ;_;
My ticket has been answered, it appears that a program I used to use left a plugin on my computer that interfered with Starcraft. The program was Hear, so if any of you are using it try uninstalling it.

As for removing the plugin if you have already removed the program go to
/Library/Audio/Plug-Ins/HAL/Hear.plugin
and drag the hear.plugin to the trash

So far everything works fine, although like others have stated my computer definitely runs warmer when playing now
Thanks, that fixed mine as well! ill throw that in the first post so that others having this issue might also be able to resolve their problems.
Thanks for the reports om this. This has been escalated to our team for review. Thanks!
Deleting hear.plugin from the folder state above solve the problem !!!

Thanks
Worked for me as well! :D
Thanks for the info, Typhoid.
I note that Typhoid's fix involves removing 'Hear'. What if I want to keep Hear?
Not possible ATM Resonance, theres some sort of conflict between the programs that screws up the game, so until that is fixed you will have to make do without one of them.
Although, i suppose you could move the pluggin file to the desktop every time you wanted to play the game, then move it back after, that MIGHT work, kinda annoying though....
Not possible ATM Resonance, theres some sort of conflict between the programs that screws up the game, so until that is fixed you will have to make do without one of them.
Although, i suppose you could move the pluggin file to the desktop every time you wanted to play the game, then move it back after, that MIGHT work, kinda annoying though....

Automator can do that.
Move the file somewhere else, launch the game (wait for it to quit) and put the file back.

Not ideal, but a easy workaround.

Join the Conversation

Return to Forum