Repair Tool Missing From Support MAC OSX

Mac Technical Support
I am using a Macbook Pro with OSX.

I went to applications--> starcraft 2, but when I try to press support, it says that there is no application to run it. I tried double clicking it and opening its contents, but I couldn't find a repair.app.

Could someone help?
But I have 10.6.8...
So is there any fix for this problem? I am having the same issue. Is it a metter of upgrading my OS to a later version?
The repair tool is built into the new updater system. If you look on the Windows client as well, the repair tool no longer exists.
Well I guess there's another reason for sc running so god damn slow on my macbook pro...
How can we repair then?
I'm having the same problem. I encountered an issue with my Starcraft 2. I tried to start a game multiple times with my friends on the same network and the game freezes at loading screen. There's no way to repair... =(
With that issue, it might be better just to delete the Battle.net cache. This is something repair does not cover.

Clearing your Battle.net Cache
    1. Navigate to Mac HD/Users/Shared/Blizzard/
    2. Move the Battle.net folder to the trash.
    3. Empty the Trash.
    4. Launch Starcraft II

Join the Conversation

Return to Forum