patch 1.4.4 error code: BLZPTS00008

Mac Technical Support
Whenever I try to install patch 1.4.4 I keep getting this error code. What do I do?
If you are receiving this message, there may be some missing or corrupt data on your hard drive.

Can you take a screenshot of what your SC2 folder looks like in Finder? I would like to see if there is any missing folders.
how can i upload the file of the screenshot on to this site?
do i have to uninstall and reinstall?
I had the same problem on my mac book pro(snow leapord) - i deleted the SC directories and still no go. I removed every trace of SC from the computer and did a fresh reinstall -- still has the same issues. This sucks.
ya i have snow leapord too when i clicked on the error code it told me to reinstall as well
also repair disk permissions
Those experiencing this error, please send me the following information after you run the game and get this error again.

Obtaining your System Information and system.log
Snow Leopard (10.6) and older versions of OS X
    1. Hold the Option Key and choose System Profiler from the Apple Menu
    2. When the System Profiler is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location. Make sure the file format is "System Profiler 4.0 (XML)"

Lion (10.7)
    1. Hold the Option Key and choose System Information from the Apple Menu
    2. When the System Information is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location.

Obtaining your system.log
    1. Using Finder, Navigate to /Applications/Utilities and open Console
    2. Click system.log on the left side bar.
    3. On the menu bar, click File, and select Save a Copy As. Make sure the file is saved to the desktop for easy location.

Submitting your system files
    1. Open a new email message, and attach the items as an attachment.
    2. Send the email to with the subject as "Attn: TonyM". Make sure you include the Thread title and URL address. This way it gets routed to me so I can take a personal look.

Please note: This method is only used for sending information after files are requested for additional review. This is not to be used a a form of contact, as this box is monitored only when files are requested. No replies are sent from here.
ummmm?? any ideas on wats goin on
am i gonna have to uninstall and reinstall??
expeirencing the error. really sucks i cant play, tried everything. uninstall and reinstall.
oh rlly the uninstall and reinstall fixed that problem for me
I have the same error too. I need my SC fix!

So I reviewed the logs and system information, but the only thing I was able to find is that the permissions for the file seem to be borked. I see this line being repeated:

Jul 31 11:48:24 [removed] [0x0-0x8f18f1].com.blizzard.downloader[19571]: 2012-07-31 11:48:24.327 StarCraft II[19572:4503] Current process is NOT running as Admin: -60007
Jul 31 11:48:24 [removed] SecurityAgent[19429]: system.privilege.admin|2012-07-31 11:48:24 -0400
Jul 31 11:48:26 [removed] authexec[19574]: executing /Applications/StarCraft II/Temp/1.5Migration-mac/StarCraft II Migration II
Jul 31 11:48:26 [removed] StarCraft II[19574]: Current process is running as Admin: 0
Jul 31 11:48:26 [removed] [0x0-0x8f18f1].com.blizzard.downloader[0]: 2012-07-31 11:48:26.749 StarCraft II[19574:4403] Current process is running as Admin: 0

So for other having this issue, try resetting the disk permissions and folder permissions and see if that helps.

Repair Permissions via Disk Utility
    1. Navigate to /Applications/Utilities/ and open Disk Utility.
    2. Select the hard drive the game is installed on.
    3. Select the First Aid option.
    4. Click on the Repair Disk Permissions button.

Resetting permissions on the Starcraft II folder
    1. Select the Starcraft II folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items
I did both the Repair Permissions and Resetting on SCII folder and still have the same problem. Now what?
i have the same issue
I have the same issue (MacBook Pro Retina, Mountain Lion). The proposed solution did not work.
same here...please help, this sucks, cant play at all :S
Hi, I'm having the same error, but i'm on a windows 7, do you think you could tell me the instructions to fix it on PC Macnkan? Thanks. I've deleted everything of SC2 on my computer and re-installed it via disk and once i get to download patch 1.4.4 and it gets to 100% it says looking for updates and then i get the error.
I' not sure if this helps any but, when I downloaded WC3 Reign of Chaos and tried playing multiplayer it basically told me the same thing " there was an error writing to your hard drive while trying to download a file from".The single player on WC3 RoC was fine. I also play WoW and i don't have any issues with this error.

Join the Conversation

Return to Forum