Language Pack Issue

Technical Support
At first, I was getting the language pack error message. After that, I've tried switching to those settings in the variable file, as this seemed to work for a lot of people:

localeidassets=enUS
localeiddata=enUS

That didn't work either, so I changed back to what it was originally and now i'm not even able to open the game, I'm getting this error: http://i835.photobucket.com/albums/zz276/bobby_978/patchfail.png

Any idea on how to fix this?
same problemo
07/31/2012 05:38 PMPosted by Nakba
same problemo


Someone told me to just deleate the variable file - done - still not working, any new ideas? :(
dont delete it!!!
07/31/2012 05:45 PMPosted by Nakba
dont delete it!!!


I've got it saved on a clip drive - just in case
Same problem, and it's weird because the menu is in french but when I click the ''options'' tab it's in english. This patch is a big piece a crap.
07/31/2012 05:55 PMPosted by Jeremie
Same problem, and it's weird because the menu is in french but when I click the ''options'' tab it's in english. This patch is a big piece a crap.


Oh, I've had that too! That is when someone told me to change the variable files from Frfr to enUS. Since I've done that, the game won't even open and says an error has occured just like in my screenshot
How do i fix this problem, I can't log in, at the log in menu its blank texts and just boxes and when i try to log in , its not working its a error text but its blank, maybe its cause i also have KR version but still. This should really happen -_-, Its downloaded in different sections of my computer. Any ideas in fixxing this?
If that helps to solve anything, I've got NA/EU/SEA version on my computer. Though I've only went on EU and NA in the past months.
This is unacceptable. The only working fix is to delete your Starcraft II folder in your documents..play a few games and then it will be back to having to delete the folder again. Retards cant do anything correctly :\
Seriously, I don't know why this patch was necessary... it's just a bunch of complications, I want to play... What's up with this bug this time?
Now, I can't even login to the damned thing. Its giving me the same error you are getting in the picture

07/31/2012 05:34 PMPosted by LGZwei
http://i835.photobucket.com/albums/zz276/bobby_978/patchfail.png
07/31/2012 06:15 PMPosted by babybell
Seriously, I don't know why this patch was necessary... it's just a bunch of complications, I want to play... What's up with this bug this time?


There weren't enough people upset with Diablo 3 so they figured might as well share some of the rage with the SC2 community
What variable file are you guys talking about?
07/31/2012 06:39 PMPosted by DJChris
What variable file are you guys talking about?


Variables.txt file in the Starcraft II folder localised in Documents.

Btw, still no response to this problem? How am I supposed to fix the "an internal error has occured".
!@#$
launch the game, no text, just blank box with no words...LOL
I also cannot sign in getting an error saying i need an authorised language pack.

Please fix blizz
Got the same problem. Did this and now it works.

You can also edit the Variables.txt file in the StarCraft II folder in the Documents folder (C:\Users\<username>\Documents\StarCraft II), and edit these lines to your region:

localeidassets=enUS
localeiddata=enUS

Also run as an administrator.
anyone know where the variables file exists on a mac version ?

Join the Conversation

Return to Forum