Required files are missing.

Mac Technical Support
It says after launch.
It happened to me b4 and resinstalling it fixed it but ive reinstalled it twice now and it doesnt work.
I was just told the same thing. It appears after the "connecting to patch server" window appears.
ya exactly my starcraft still cant open
me too, I've tried the posted advice and it is not working :(
Im having the same problem. I have reinstalled it enough times to know that that isn't going to fix it. Please post if anyone has resolved this issue.
during your reinstall ... did you go into your user library folder and delete (1) the blizzard / SC2 prefs and then (2) also the application support items. After that go up to your user / shared folder and delete all the blizzard/battlenet items.

Then try a clean install. Currently having to download the installer as CD won't run as it reports not enough hard drive space (1.5 TB isn't enough for it apparently).

I'll try and post a success or fail update.
update on my attempt. everything finally updated properly. for it to work though I had to:

1. delete all preferences stored in my user folder and in the shared user folder.
2. delete my original starcraft 2 game directory (which I had not installed into the default applications folder).
3. download the SC2 game installer and then run it (installing into apps folder)
4. run the patches
5. finally launch the game and get back to playing

hope this helps.
Every time I try to optimize I get a failed to download file. My connection is O.K. and I have restarted my P.C.
It dosnt say what file
This is an old thread, and it is relating to a different issue. Can you create a new thread with the issue at hand so we can better assist?

Join the Conversation

Return to Forum