Starcraft 2 won't load after patch downloaded

Mac Technical Support
I followed the steps for dwnlding patch 1.5.0 and everything seemed to work fine. The patch completed and I got 100%. But now whenever I open up Starcraft 2 it opens up the blizzard launcher and says connecting to patch server. However, it wont open anything and then I have to force quit the program because it isn't working. I have a mac. Please help.
Also after I force quit, I get a pop up that says that some required files were missing and I have to reinstall starcraft 2. But I don't understand.
I have the same problem. Also Mac.
I'm having the same problem! I'm concerned, because this problem was not mentioned on the known mac issues" forum page, and none of the recommended fixes in the troubleshooting forum page are working for me. I submitted a ticket, and they tried to help, but eventually said to wait until a new patch is made to fix the problem within a few weeks. But if this problem isn't on the known issues page, how do we know that the patch will include a solution to this problem?
Also Mac v10.6.8
Same problem, v10.6.8
Same problem, even after a reinstall. v10.7.4 on a Nov 2011 MBP
Saw this in another thread. Worked for me.

1. Hold down the Option (Alt) key and select Library from the Go menu.
2. Navigate to ~/Library/Application Support/Blizzard and move the StarCraft II folder to the Trash (or move to the desktop to save any replays).
Soooo we're pretty much screwed? lol
Its been a week and they haven't done anything about it. Guess its time to throw in the towel.
--How does a patch that for the most part, completely eliminated mac users...get released?
This is total BS.. i haven't been able to play for a week :( and really hardly any word or apologies or ANYTHING from blizzard. Damn you blizzard, damn you to hell.
I have the same problem. How lame...
Same Problem. WTF Blizzard... WTF indeed.
Did you try this and see if it helps?

    1. Force quit SC2, Agent and Blizzard Launcher processes in Activity Monitor.
    2. Launch StarCraft II.
    3. When the game prompts to enter in your administrator username/password, hit Cancel.
    4. StarCraft II should load properly.
The log in window doesn't even show up, It acts like it is loading and the wheel spins for a second, but no screen shows up at all. I called support once and for a work around: It only worked once, but for all of you who haven't tried it, try this:

1. Open StarCraft folder in finder under Applications.
2. RIGHT CLICK Launcher.db and open it in TextEdit
3. Type "enUS" and click save. (when I did it three dots appeared when I opened the file, YOU MUST DELETE THESE in order for this to work) If they don't show up don't sweat it.
4. Relaunch the game.

this worked for me for ONE DAY only, BUT it gave me a few hours that day of play time. Besides that I am currently on hold with blizzard awaiting someone to give me some hope as to how to fix this.
This is the last straw... seriously Blizzard? Are you trying to drive customers away?
I don't know about you guys, but it seems like with the download of patch 1.5.1 starcraft IS working again. Idk how it did it but I am able to log on and play. I guess I just have to cross my fingers and hope it stays like that.
we need snow leopard. we have to !@#$ing buy snow leopard.
08/15/2012 03:11 PMPosted by FunkAdizzY
we need snow leopard. we have to !@#$ing buy snow leopard.
Considering it's not even a supported OS anymore, why wouldn't you update? The only reason you should honestly have is that you don't have an Intel Mac, otherwise, you're leaving your computer wide open to vulnerabilities and honestly one of the worst bloated graphics APIs.

It was one of the reasons why my iMac has been just running in Windows for the longest time, because the games played much more smoothly than they do in OS X, which means I can throttle the settings a bit more and get a more pleasing visual experience from it. Yes, they can still run faster and smoother in Windows, but the updates brought in 10.8 have definitely closed the gap quite a bit since they've brought some much needed updates to the graphics API, and now I actually don't feel obligated to keep my iMac in Windows as much anymore.
I'm having the same problem but I'm using Windows. Anyone else on windows having the same problem?

Join the Conversation

Return to Forum