Starcraft 2 won't load after patch downloaded

Mac Technical Support
08/15/2012 08:36 PMPosted by senecawolf
I'm having the same problem but I'm using Windows. Anyone else on windows having the same problem?

You will want the Windows tech forum:
Hi so i go to play star craft today. Have not played it in a couple of months or so. I launch it like I do every other time, updater comes up and starts dl new patch. Dl new patch then it starts applying the patch,about 15 sec in completely closes down. I try to re start just keeps doing the same thing. I am running Mac OS X 10.5.8 reading through the forms looks like there have been a lot of problems. So are there any fixes???
Mac OS X 10.5.8 isn't supported as of patch 1.5. You can read more about this here:
Yep I am
The log in window doesn't even show up, It acts like it is loading and the wheel spins for a second, but no screen shows up at all. I called support once and for a work around: It only worked once, but for all of you who haven't tried it, try this:

1. Open StarCraft folder in finder under Applications.
2. RIGHT CLICK Launcher.db and open it in TextEdit
3. Type "enUS" and click save. (when I did it three dots appeared when I opened the file, YOU MUST DELETE THESE in order for this to work) If they don't show up don't sweat it.
4. Relaunch the game.

this worked for me for ONE DAY only, BUT it gave me a few hours that day of play time. Besides that I am currently on hold with blizzard awaiting someone to give me some hope as to how to fix this.

Very strange fix, but it worked for me...
Ever since the last patch came out GAME FREEZES AT LOADING SCREEN

on mac

Join the Conversation

Return to Forum