1.5 Patch hangs during update

Technical Support
To anyone who can provide assistance.

When the 1.5 patch was released SC2 began downloading it. It seemed to go ok until it threw an error about an inability to write to drive, check that there is free space and try again, yada yada. I have plenty of free space on the drive.
Because this error cancelled my update process, I began it again. It ran through part of its process, and one time it loaded the old interface but wouldn't let me log in. I continued trying to update and 3 or 4 times it would fail in a different way.
Now every time I try to load the game it goes straight to a SC2 launcher msgbox that says updating setup files, and refuses to finish the progress bar it starts. It gets about 60%, hangs, eventually flickers a line that says something like "launching blizzard updater" but it goes back to "updating setup files" almost instantly, repeat ad infinitum.
Once I realized it was just going to do that forever, I tried uninstalling the game and redownloading off of b.net. After that I deleted my Starcraft II folder but didn't uninstall it, then I copied the Starcraft II folder off of another laptop that had the 1.5 patch, I think I tried one or two other things but nothing has changed, it just keeps getting stuck at 60% and hanging forever... :(

*edit: To clarify, it doesn't "hang" as in freeze completely. It just won't progress past a certain point
I was installing the game on a new laptop and had this same problem. Anyone know how to fix it?
DJack, these suggestions may help:

http://us.battle.net/support/en/article/starcraft-ii-patch-troubleshooting-pc

Please let us know how it goes, and we can work from there.
________________________________________________
Technical Support
http://us.battle.net/support
'Constant change is here to stay.'
Even the standalone patch won't install. It still gets stuck at around 60% when it is "updating setup files"
I am having exactly the same problem. Doing a fresh install and it just hangs on Updating setup files.
my old hardrive crashed so I'm installing StarCraft II on a new PC. Installation runs fine, but on launch it goes into starcraft II setup and gives me Error code: BLZPTS00009 which indicates lack of room on my nearly empty 1TB hardrive. I temporarily disabled my mccaffee firewall and tried a couple more times with the same result, but on the third try, I got the same setup error window, BUT, the SartCraft II Optimization window launched with a little bit of game music too. It said StarCraft II needed to be optimized and that would take 15-60 minutes. fingers crossed. YAY! successful install, AND battlenet remembers where I left off in the campaign too, so I don't have to start all over. woot!

Join the Conversation

Return to Forum