Patching and Migration Work Around

Bug Report
With the addition of streaming and the data migration process for getting builds before 2.0.4 up to the newest patches, occasionally the tools can become corrupt or the migration can become "stuck" or error out.

A work around process that has been known to resolve these issues involves deleting and re-downloading the latest installation Tools.

You can do that by deleting the and Blizzard Entertainment folders found in:
-Win7: C:\ProgramData\
-XP: C:\Documents and Settings\All Users\Application Data\
-Vista: C:\ProgramData\Blizzard Entertainment\
-Mac: Users/Shared/

Note: PC users will need to go into folder options to make sure that hidden files are visible in order to access the folders containing the target directories.

After the directory has been deleted you should be able to run "StarCraft II.exe" again and download the most updated Tools available. This will also restart any data migration process that may have become stuck or unresponsive.
I have deleted the folder but it did not work! = ( Heelllllp!!!
Hello, I am experiencing some serious issues with my Starcraft 2 game. My game worked fine 2 days ago after I downloaded Patch 1.5.0, I had no problems. Unfortunately, ever since my computer has attempted to download 1.5.1, it never launches the game and I get an error message saying "Failed to download a required file, check your internet connection and try again."

I have tried everything recommended in the forums and on the support website in the past two days.
I have changed my system to administrator.
I have changed permissions in my firewall/security.
I have tried changing my district from NA to SEA.
I tried deleting the folder described above.
And before that I tried downloading the Starcraft 2 installer. I am about to reinstall Starcraft 2 onto my computer but I wanted to add this post before that since the installation is going to take awhile.
I am at my wits end here. My computer and SC2 were running completely fine after the 1.5.0 patch, I have only been experiencing these issues since my computer tried to install the 1.5.1 patch. I have no idea what I'm doing wrong as the installer never even gets past 0% before I get the error message.

I've tried everything, please help. I'm using an HP Pavilion with Windows 7.

I have also deleted the folder and attempted getting the new tools to no avail.
Is there anyway to direct download the new tools or patch 1.5.1?
I can't get passed 1.5.0.
Blizzard can you please give us an update i have not been able to get on in 6 days..... Do you have anything that might help us?
I also am having this problem and nothing i have tryed has worked :(
still not working
I am a user and there is one more important step listed below for reloading game:

Step 1 : Uninstall SCII
Step 2 : Go to "Control panel", "Folder Options", select the option to show "hidden files and folders".
Step 3 : Go to "c:/ programdata" and deleted both "battlenet" and "blizzardentertainment" folders (without step 2, you won't find them) or search file names and delete
Step 4 : Reinstall, run patches and you're good to go

Note:When you try to install without all files being removed, it lists them for you and says may cause a problem. Remove that list and hidden folders is the key to finding them trust me lol
While downloading the patch it seems that it got stuck at 91%. It says initializing but nothing happens. The play button is grayed out and I can't play SC2 anymore. Anyone know the solution? Would be much appreciated if someone can tell me how to fix it!
Can someone help me?
I am facing this problem.. Tried to look for the download but none available anymore
This is how I got mine to run after it would download the migration file then crash on the client. It seemed to download that file then error as it was loading, I finally got it to work doing this on my Windows7. Find the update file in your Starcraft Folder.
Right click the migration setup file in you Starcraft folder, selected properties, then at the lower part on the first tab I noticed by the advanced button an unblock button was there. I told it to unblock and applied, then set it to run as administrator and put it in xp sp3 compatible mode. Applied the changes and re-ran it. The installer worked properly, the client started and it began working and downloading. Hope that helps.
Works for this one too, if you set the file properties before you begin StarCraft-II-Setup-enUS.exe that you get here for the full online install.

Just a note: After I got it running next day it stuck on the client bar. I cancelled it and I set the program start icon properties (Desktop Icon- StarCraft II), by just setting the compatibility (XP SP3)and setting it to run as admin, no unblock button was on it. Set it under advanced for all users, applied, checked to be sure, and back up and running again.
BLIZZARD YOUR PRODUCT IS SHAP. I'm really tired of having to spend a few days finding work-a-rounds to make your latest patch install on my computer. I want a refund.
i get a fatal exception error when trying to load exc 0xc0000005 access violation at 023:10017914 any one else get this error and know how to fix

Join the Conversation

Return to Forum