*EDIT* FIX FOUND *EDIT*Patch 1.5 won't update

Technical Support
I've completely uninstalled Avira and Spybot, I've confirmed that secondary logon is on, I've attempted to install in Safe Mode. I've attempted to install with another admin account. I've completely bypassed my router, I've completely turned off Windows Firewall. I've deleted C:\ProgramData\Battle.Net I've tried running in admin. I've tried running sc2-x.x.x.x- directly in admin. Nothing works.

When I start Starcraft 2 it says updating, 90.7 MB remaining, then it skips to 100% and crashes.

It creates two files in the Starcraft folder one called sc2-x.x.x.x- that is 5 megs and one called sc2-x.x.x.x- that is almost 4 megs.

When I try to run the sc2-x.x.x.x- directly, it opens for a second says there is 86.5MB remaining, then immediately crashes.
Exact same problem here. Tried everything short of a full re-install.

just finished like 7+hours of reinstalling only to get stuck at this exact same spot.
I just tried installing Selective Startup mode. That didn't work either.
I've been checking these forums daily and all I keep seeing is one poor tech support guy stuck posting the same responses on multiple threads. There is obviously something wrong, why isn't there at least a statement from Blizzard stating: "We know there is a problem and many of you can't patch. We're working on a solution and it should be ready within XXX days."

I reinstalled completely again. But this time when SC2 started doing all the old patches, I noticed that the migration exe had already downloaded. So I started the migration patch before the other 24 patches had installed. This allowed me to run the migration patch and I am up and running.
Hello Nomikon, I'm with the same scenario as yours. I tried to installed SC2 from the DVD (SEA version) and got stucked on "updating, 90.7 MB remaining" then crashes. What I did is after the crash, I ran the sc2-x.x.x.x- on Administrator level, then encountered the Error Could not connect to tracker!. To make this continue on downloading, do not hit the OK button or the close button. Let it stay as it is still downloading the 86.5MB file. You can verify if it is finished in downloading in the Windows Task Manager => Networking Tab.


After successfully downloading the 86.5MB file, you may now see the :\Program Files (x86)\StarCraft II\Temp\1.5Migration\StarCraft II Migration Setup.exe. Run this file to start the "Starcraft II Optimization" stuff. If you encounter the BLZPTS0000J Error, just delete the C:\ProgramData\Battle.net folder, then run again the :\Program Files (x86)\StarCraft II\Temp\1.5Migration\StarCraft II Migration Setup.exe.
My problem was different than yours, but I had already found a fix in the post above yours.

If you were getting the "Could not connect to tracker!" error message it's due to a firewall issue or router setup issue.
All I had to do was go to \starcraft II\Temp\1.5Migration and delete the .part files. It downloaded properly when I started SC up.
Jehuty, This is the same issue I am having an working on now. A friend of mine did this and it worked so lets hope it works for me also.

Join the Conversation

Return to Forum