Blizzard Launcher not working...

Mac Technical Support
This sounds like a permission issue. Try this:

Resetting permissions on the Starcraft II folder
    1. Select the Starcraft II folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items

Also, the repair tool is integrated into the game itself and will auto repair when it detects missing or corrupted data.
I have read and write permissions. Still doesn't work.

Any other possible solutions or do I need to reinstall now...? :/
Can you try deleting the folder in Users/Shared and let it rebuild the data there? This may help. Make sure you kill any Agent, Blizzard Launcher or StarCraft II processes in Activity Monitor:
As I was trying to delete the folders a few files were apparently in use. Among them were files named "Agent" and such, yet I have no Blizzard applications open...

In any case, now the launcher tries to initialize and then says that there's been an "Unexpected file management error" ...

Thanks for your prompt help, btw.

Edit: Something that may be relevant: during the maintenance I started downloading a EU client, and in the middle of the download I got the same error that I just got for my NA client (the Unexpected file management error).

This seems like a good time for that auto repair to kick in...
OK, made sure I killed everything SC2 related in Activity Monitor. I'm gonna double check to make sure I didn't miss anything but the problem remains:

unexpecetd file management error... Is there any way to make the repair tool attempt a repair...?

Hrm? That is a new error.

The repair tool is integrated into Agent now. Can you send me your system files so I can check this out?

Obtaining your System Information and system.log
Snow Leopard (10.6) and older versions of OS X
    1. Hold the Option Key and choose System Profiler from the Apple Menu
    2. When the System Profiler is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location. Make sure the file format is "System Profiler 4.0 (XML)"

Lion (10.7)
    1. Hold the Option Key and choose System Information from the Apple Menu
    2. When the System Information is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location.

Obtaining your system.log
    1. Using Finder, Navigate to /Applications/Utilities and open Console
    2. Click system.log on the left side bar.
    3. On the menu bar, click File, and select Save a Copy As. Make sure the file is saved to the desktop for easy location.

Submitting your system files
    1. Open a new email message, and attach the items as an attachment.
    2. Send the email to with the subject as "Attn: TonyM". Make sure you include the Thread title and URL address. This way it gets routed to me so I can take a personal look.

Please note: This method is only used for sending information after files are requested for additional review. This is not to be used a a form of contact, as this box is monitored only when files are requested. No replies are sent from here.
So... should I reinstall?

If it's helpful at all, the first time I saw that error that is apparently new was when I tried to install the EU version.

If only Blizz had included multi-regional access instead of making me buy another copy just to play with different people...

In any case, thanks for your help. Looking forward to hearing from you.

Edit: My apologies. Thought I had sent the e-mail earlier but I did not... Sent now!
I see you have multiple versions of StarCraft II, and the beta. Do you know if you can just remove all other versions of Sc2 and just leave /Applications/StarCraft II/ alone? Delete the setup of SC2 you have in your downloads folder.
Deleted the setup I had in my downloads folder and deleted all the versions of Starcraft in my applications folder... Still nothing.

Something to note: before I did all of this, I tried to open SC again and did not get the error... Just went back to seeing a picture of the hyperion (background of the launcher) while the play button remained grey.

After downloading the files you told me to, nothing has changed.

Lets try one thing. Can you delete the MPQ file located in /Applications/StarCraft II/ This should force the game to look at itself, reconfigure what it needs and download the missing data. Let's see if that works.
I have been following along with this and nothing has worked for me either. is it a problem with the HEAR plugin that i saw on other posts or do you have any more info? Me and two of my friends are unable to play and we are all having the same exact problems a response would be much appreciated.
i have the similar problem except that it quits at jim raynor loading screen.
i have removed HEAR plugin and done the the suggested on this post
I am also having the same problem as Jambon, but it is also affecting Diablo 3.
The WOW 5.0.3 patch just came out and im having the same issue. I'll open the launcher, a quick tool update will start and when finished (only about 3 seconds long) the launcher will shut down. When I restart the launcher the process repeats itself. When the SC2 v2 update came the same issue came up, but being that im not an avid SC2 player I did not care. I'm a huge WOW player so if anyone finds out how to fix this I would greatly appreciate it.
I also have been staring at a grey play button all day... Very annoying
Tried deleting the Battlenet.MPQ file. Didn't work.

There have been a ton of reports involving this bug, and I have heard that it affects the installer too so that we can't even re-install. I myself have not tried because of the several instances that I heard about.

It's been a week that this has been going on. Once again, I realize that I am yelling at the wrong person and I apologize, but has there been any update regarding the matter? I'd like to play...

P.S The same issue is affecting my Diablo 3 application.
Hey JambonRose,

Can you send me your log files so I can look more in-depth?

    1. Navigate to Users/Shared
    2. Right-click the folder and select Copy
    3. Right-click anywhere on the Desktop and select Paste item.
    4. Go into each sub folder (Agent, Agent.[build], Client, Blizzard Launcher.[build], Setup) in the new folder on your desktop and delete the any following:
  • Any (the application itself)
  • Any Blizzard (the application itself)
  • Error Reporter
  • Any World of Warcraft, Diablo III or StarCraft II Setup files
  • 5. Now right-click the folder and select Compress ""

Now you can email the compressed (zip) file to This way I have all your logs and can investigate further. Make sure you put the URL and thread title in the body so I can know what issue we're talking about.
Unfortunately, I won't be able to do this until sometime tomorrow night as I am away on a short trip. I really do appreciate your responses, though. Expect to hear from me in a day or two!

Thanks again,

Join the Conversation

Return to Forum