Downloaded P 1.5, Launcher Issue

Mac Technical Support
Downloaded P 1.5 yesterday, and the launcher will not allow me to press the play button to enter the game. It just shows the battle cruiser and the play button remains grey.

I tried to repair permissions, etc. and it is not working. This is really frustrating. Please HELP!
What happens when you delete the Battle.net folder in Users/Shared? This should re-create the launcher tools and may help you.
Thank you for the prompt reply. Where is this users/shared folder?
Found it. Okay launcher works now, but not battle.net.
Battle.net? as in? what happens when you attempt to login?
It says my internet connection may not be connected (but it in fact is). I just exited the game, and re-started it again. It updated some files, and now the same problem is occuring again. Launcher play button is grey...
Message received "an unexpected error has occurred" and has asked me to restart the launcher...
Can you try deleting your Battle.net.MPQ file in /Application/StarCraft II/Battle.net. This forces the game to evaluate the game files and force any updates through.
Ok just did that. Same problem.
said "initializing" on bottom right corner, and then concluded with "an unexpected error occurred while updating required files. Please try again"
same issue .. bump!!
can some1 help me if i click play it just says that it didn´t find the icuuc44.dll file.

Join the Conversation

Return to Forum