Starcraft wont launch

Technical Support
I've tried launching it from steam, which normally works, as well as launching it from the taskbar (bottom of the screen) and from the file location, as well as launch as an admin, but no matter what I do, it "loads" persay for a couple seconds without opening anything and then acts as if I never clicked anything.
I have absolutely no clue what might be the issue, so it'd be great if you could help.
Let's try these steps, Masterman, we can work from there:

1) Boot into a Selective Startup
2) Delete the cache
Technical Support
'Constant change is here to stay.'
Alright. I'm in selective startup and I'm looking for the cache.
I'm not seeing it anywhere, despite about 10 minutes of google searches and a multitude of different location checks.

I'm gonna assume it's the text file named "battlenet" but im not deleting it till thats confirmed.
Next steps?
My apologies, here's how to see the C:\ProgramData folder:
Technical Support
'Constant change is here to stay.'
Page not found
(note, my bad. I fell asleep. it was like, 2 am where I am.)

found it.
I'm in C:/ProgramData/
there's no folder in here, am I supposed to delete the one in Program Data?

*edit 2*
also, I'm about to leave and I wont be able to do anything in terms of using my computer for about 30 hours. I guess if you could bookmark this thread that'd be nice. once I'm back I'll be here pretty constantly.
08/23/2012 03:26 PMPosted by MasterMan

That's it, delete the folder in C:\ProgramData
Technical Support
'Constant change is here to stay.'
looks like that wasn't actually all that needed to be done. if I launch starcraft it updates as well as bringing up a second window that gives me the option to launch. if I launch it says something about corrupt files that's cut off midway.
!@#$%^-it, why cant games just be simple.
Well, I dont know what you're doing, but wherever you are.
I backed up my computer to when I first started this forum, deleted the battlenet folder and now I patiently await further instructions.
I'm having similar issues, except I've gone as far as deleting in programdata, uninstalling everything related to SC2, and found my SC2 disc.

I just tried to reinstall from disk, as the website installer wont work. I am constantly getting virus messages from AVG, and when I turn it off, I get an error saying I don't have permission to access the file. I get the same error from the online installer.
this is what I get when I try to uninstall
when I try to use the repair program it says "Unable to repair, please reinstall starcraft"
I reinstall and I get this
which based on what it says I'd assume is normal, but if I carry through it doesnt overwrite them.
I feel maybe I need to actually find the files mentioned in the first image and forcibly remove them.
hit the windows button and type "run" into the search bar
Enter this into the search bar. "C:/Programfiles(x86)/Starcraft II/Support"
and run the program called "Starcraft II repair"
it may simply be called "repair"
Try also typing into the search bar "Starcraft"
The uninstaller should come up along with the other .exe files, see if it gives you a similar error message.

Join the Conversation

Return to Forum