Patch 1.5.2 Failed to Download Required File

Mac Technical Support
Every time I try to download patch 1.5.2, the progress bar stays at 0% Initializing. After about 5-10 minutes of waiting, I get a notification saying 'Failed to download a required file. Please check you internet connection and try again.'

I have tried several different local connections, turned off and even removed my AV software, turned off peer to peer download (I'm at college), and tried various 3rd party download clients... still nothing.

This is kind of frustrating, and I'm hoping that Blizzard can fix this ASAP. I know I'm not the only mac user who has this problem, and I hope future patches can avoid this kind of hassle.
@ squidman
i am having the same problem, i believe it has some thing to due with the fact that we are trying to do it at a college. because when i first saw that i had this problem i went back to my actual house and i was able to download the entire update, but since i came back here it still has the failed to download the required file sign that pops back up. so more than likely it is just the internet at the colleges not being able to support the download or something.
This might be related to the network itself. When you stated you tried at different local connections, were those also on the college network?
I'm also having the same problem..I just moved into college also. I came home to download starcraft at my house but it keeps giving me the same message.
just give a link to manually download
@ Machkan: No, the first network was the college. The 2nd was a local Panera Bread. And the third was my friend's personal wifi at his house.

I tried it with Peer to peer on and off at all three locations, hoping I might strike lucky with it. Alas, no luck as of yet.
Can you run the launcher one more time. When you get the error, close the launcher.

Then send me the most recent Agent-YYYY/MM/DD-[Random Numbers].log file in Users/Shared/ along with your system files:

Obtaining your System Information and system.log
Snow Leopard (10.6) and older versions of OS X
    1. Hold the Option Key and choose System Profiler from the Apple Menu
    2. When the System Profiler is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location. Make sure the file format is "System Profiler 4.0 (XML)"

Lion (10.7)
    1. Hold the Option Key and choose System Information from the Apple Menu
    2. When the System Information is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location.

Obtaining your system.log
    1. Using Finder, Navigate to /Applications/Utilities and open Console
    2. Click system.log on the left side bar.
    3. On the menu bar, click File, and select Save a Copy As. Make sure the file is saved to the desktop for easy location.

Submitting your system files
    1. Open a new email message, and attach the items as an attachment.
    2. Send the email to with the subject as "SC2: Failed to download a required file". Make sure you include the Thread title and URL address. This way it gets routed to me so I can take a personal look.

Please note: This method is only used for sending information after files are requested for additional review. This is not to be used a a form of contact, as this box is monitored only when files are requested. No replies are sent from here.
can you plz just give a manual download ffs
Yeah, what buck said. Nothing I'm trying is working...
@ Machkhan, I just sent the email with the required data. Let me know if you need more information.

Select your region and then follow the directions. This worked for me and I am currently on a
college network.
Try what Fate suggested, as this appears to be an issue with the network blocking ports and preventing the data from downloading.
I have the same issue. Maybe its something on mac computers? I use a mac desktop :/
Tried what Fate suggested, it seemed like a good idea. Same error though. Nothing seems to work..
Do y'all have any AgentError logs in Users/Shared/ If so, can you post the contents of it? Make sure to remove any personal information.
I have a PC laptop at college. Same issue, but the .tfil fixed it to my satisfaction after that one file the rest downloads fine. I had just fixed the main problem with the Agent.
I am not at college. I am sitting my apartment....same issue.
Having the same issue right now, at a college. Did a new install since the patch wasn't working, get this error every time.

"Failed to download a required installation file ( Please check your internet connection and try again."

Obviously I'm connected to the internet if I'm typing this. What should I do?
Can you send me your Logs? This will help us investigate the problem.

Obtaining Logs
    1. Navigate to /Users/Shared
    2. Right-click the folder and select Copy
    3. Right-click anywhere on the Desktop and select Paste item.
    4. Go into each sub folder (Agent, Agent.[build], Client, Blizzard Launcher.[build], Setup) in the new folder on your desktop and delete the all following apps:
  • Any (the application itself)
  • Any Blizzard (the application itself)
  • Error Reporter
  • Any World of Warcraft, Diablo III or StarCraft II Setup files
  • 5. Now right-click the folder and select Compress ""

Now you can email the compressed (zip) file to This way I have all your logs and can investigate further. Make sure you put the URL and thread title in the body so I can know what issue we're talking about.

Join the Conversation

Return to Forum