Jumpy Mouse Issues

Mac Technical Support
During games, but only ladder games my mouse jumps anywhere from a few cm to a few inches away and back and forth several times, then stops in the middle. I never had this issue before the 1.5 update. It doesn't happen with games like team fortress 2 or counter strike source, so it's not my mouse, nor is it my computer. I believe this is a problem with the game and it needs to be fixed, i do play on a mac if that has anything to do with it
Iv had the same issue but its fine for me in windowed with the confine curser option on auto. this problem started with 1.5. it is frustrating but I haven't tried it in any other settings for a wile because I'm to scared that I will happen agin :(
Can you tell me if toggling the confine cursor option helps in any way?

In any case, I've escalated this to the team and they are investigating this matter.
I will try all confine cursor options and come back.
OK SO! I have tried all options and if i have the game in full screen this happens and if i have it in windowed with confined mouse curser on, but i don't seem to have trouble with mouse on auto and the game in widowed form. It's like It stutters then jumps but not all the time. Also I'm on a macbook pro with OSX 10.8.1
i have this problem too ... but mines because i spilled a lot of drinks on my mousepad so ...
Thanks for the report on this. I'll send the feedback up.
Is there any update regarding these mouse issues. I am a mac user with the same issue.
Let me see what I can find out. Thanks for the bump.

EDIT:

Can you post some system information?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)


  • Also, are you using a dual display setup?
  • Finally, have you tried to toggle the confine cursor settings like mentioned above?
  • Model Name: MacBook Pro
    Model Identifier: MacBookPro7,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Memory: 4 GB
    Bus Speed: 1.07 GHz
    Sudden Motion Sensor:
    State: Enabled
    Chipset Model: NVIDIA GeForce 320M
    ROM Revision: 3533
    Displays:
    Color LCD:
    Resolution: 1280 x 800
    Pixel Depth: 32-Bit Color
    System Version: Mac OS X 10.6.8

    I am not using a dual display and I have not tried toggling the settings yet
    I am a mac use with the same issue

    Join the Conversation

    Return to Forum