"Failed to read a required file."

Technical Support
Alright so I did the read only thing but there are no StarCraft II.tfil and StarCraft II.mfil files. I tried loading SC2 and it still say Failed to write to the required file. Please close all other applications and temoraily deactivate your antivirus still.
Unless you haven't updated SC2 to 1.5 yet (not likely considering the error you're getting) it's unlikely that you don't have those files.

These are the files I have in my SC2 folder:
https://dl.dropbox.com/u/16147711/sc2.png
I can't update to 1.5 because of the error, therefore not letting me play the game.
09/23/2012 06:02 PMPosted by Vezon
I can't update to 1.5 because of the error, therefore not letting me play the game.

Can you go in StarCraft II -> Temp -> 1.5Migration, right click StarCraft II Migration Setup and Run as Administrator?

If that fails, reinstalling the game is an option. But download the installer from us.battle.net/account
Starcraft 2 as in the program or the folder? And where is this temp option? Sorry for being a pain.
09/23/2012 07:27 PMPosted by Vezon
Starcraft 2 as in the program or the folder? And where is this temp option? Sorry for being a pain.
The folder. "StarCraft II\Temp\1.5Migration\StarCraft II Migration Setup.exe"
Bro... your the BOOM! this solution works!

09/18/2012 05:31 PMPosted by eld
Hey I'm having the same problem and I re-installed the Index.SC2Locale and Product.SC2Archive files and nothing.
Those files wont fix the 'failed to read' error.

For the failed to read error, first reboot your computer and if you get the same error, you need to check a log file to find out which file is causing this.

So, assuming rebooting didn't help:

1. Go to:
C:\ProgramData\Battle.net\Agent\Agent.xxxx\Logsxxxx = Highest number. (probably 1267)

2. Open the most recent AgentErrors log and, in it, you should find the error and the file that's causing the error.
3. Now delete the file shown in the log and try again.
Hey guys all you need to do is delete this file

C:/Program Files (x86)/StarCraft II/Mods/Challenges.SC2Mod

You're welcome! :)
09/18/2012 05:31 PMPosted by eld
Hey I'm having the same problem and I re-installed the Index.SC2Locale and Product.SC2Archive files and nothing.
Those files wont fix the 'failed to read' error.

For the failed to read error, first reboot your computer and if you get the same error, you need to check a log file to find out which file is causing this.

So, assuming rebooting didn't help:

1. Go to:
C:\ProgramData\Battle.net\Agent\Agent.xxxx\Logsxxxx = Highest number. (probably 1267)

2. Open the most recent AgentErrors log and, in it, you should find the error and the file that's causing the error.
3. Now delete the file shown in the log and try again.


simplest...solution...period.

Ps: wow, blizz, just blame it on the anti-virus...
09/18/2012 05:31 PMPosted by eld
Hey I'm having the same problem and I re-installed the Index.SC2Locale and Product.SC2Archive files and nothing.
Those files wont fix the 'failed to read' error.

For the failed to read error, first reboot your computer and if you get the same error, you need to check a log file to find out which file is causing this.

So, assuming rebooting didn't help:

1. Go to:
C:\ProgramData\Battle.net\Agent\Agent.xxxx\Logsxxxx = Highest number. (probably 1267)

2. Open the most recent AgentErrors log and, in it, you should find the error and the file that's causing the error.
3. Now delete the file shown in the log and try again.


You are both a gentleman and a scholar, good sir. Thank you.
Ok so not good with computers. I know that this file is causing my issues, but dont know how to get rid of it.

This one is the problem: C:/Program Files (x86)/StarCraft II/Mods/Challenges.SC2Mod

Dont know how to find the file to delete. There isn't a mod folder?
09/18/2012 05:31 PMPosted by eld
Hey I'm having the same problem and I re-installed the Index.SC2Locale and Product.SC2Archive files and nothing.
Those files wont fix the 'failed to read' error.

For the failed to read error, first reboot your computer and if you get the same error, you need to check a log file to find out which file is causing this.

So, assuming rebooting didn't help:

1. Go to:
C:\ProgramData\Battle.net\Agent\Agent.xxxx\Logsxxxx = Highest number. (probably 1267)

2. Open the most recent AgentErrors log and, in it, you should find the error and the file that's causing the error.
3. Now delete the file shown in the log and try again.


Thanks so much! <3
thanks fixed for me.
[/quote]
You're probably missing the Product.SC2Archive and Index.SC2Locale files. These files are created when you install the game and are one of the few files the launcher won't re-download when deleted.

Product.SC2Archive / Index.SC2Locale - enUS version.
http://patchup.info/files/sc2/enUS/Product.SC2Archive
http://patchup.info/files/sc2/enUS/Index.SC2Locale

Save them in the "Mods\Core.SC2Mod" folder.
StarCraft II\Mods\Core.SC2Mod\Product.SC2Archive
StarCraft II\Mods\Core.SC2Mod\Index.SC2Locale


Index.SC2Locale is a text file and Product.SC2Archive is a MPQ file which contains a single text file.[/quote]

This fixed my issue, thanks.
This for mac os x, not mountain lion, anyway I started Starcraft 2 and the updater's download speed immediately started dropping, when is started telling me less than one kb/sec i decided to restart the launcher only to get the "failed to read required file error". Anyway accessing mods in the Starcraft 2 folder I deleted Challenges.SC2Mod and Core.SC2Mod leaving Liberty.SC2Mod and LibertyMulti.SC2Mod alone. Just restarted the launcher and successfully updated, no promises but it's worth a shot.
thanks man i tried everything for 2 days and that finaly worked lol even wrighting a ticket didnt help
Tried looking up the Agent error. I deleted the problematic file. Still getting the patcher error message.
well i took a drastic move and uninstalled and now it wont install it just stops at the file down load section.

can any one help
I have the same problem, but ive tried everything known to man on the internet and common procedures to fix it, and nothing, i guess i have a useless game taking up space until they fix it, glad to see im not the only 1 though

Join the Conversation

Return to Forum