Patch 1.5.3 "An Internal Error Occurred"

Mac Technical Support
After installing patch 1.5.3, Starcraft II worked once. Every time I open the game since, the launcher screen opens and a popup says:

"An internal error occurred, please restart. If problems persist contact customer support."

Restarting the game does not help. Nor does restarting my computer.

Any help would be greatly appreciated.
How are you opening StarCraft II? From a desktop shortcut?
From a shortcut on my dock. I have tried directly launching the StarCraft II.app in my applications folder and i get the same error.
JohnnyClassic, can you send me your Battle.net logs so I can see what specifically is happening?

    1. Navigate to Users/Shared
    2. Right-click the Battle.net folder and select Copy Battle.net
    3. Right-click anywhere on the Desktop and select Paste item.
    4. Go into each sub folder (Agent, Agent.[build], Client, Blizzard Launcher.[build], Setup) in the new Battle.net folder on your desktop and delete the any following:
  • Any Agent.app (the application itself)
  • Any Blizzard Launcher.app (the application itself)
  • Error Reporter
  • Any World of Warcraft, Diablo III or StarCraft II Setup files
  • 5. Now right-click the Battle.net folder and select Compress "Battle.net"

Now you can email the compressed (zip) file to macsupport@blizzard.com. This way I have all your logs and can investigate further. Make sure you put the URL and thread title in the body so I can know what issue we're talking about.
Thanks for the reply Machkhan. I've emailed the requested information.

I've figured out a temporary work around which might allude to the cause of the problem. I can start Starcraft II using the Starcraft II Editor and the game works fine. But I still can't launch the game the normal way.

Thanks again.
I've viewed the files and something is definitely weird. I see you were launching normally:

#-----------------------------------------------------------
# System started at 2012-09-18 23:52:51.2349
# system: [removed] Mac Pro
#-----------------------------------------------------------
23:52:51.2362 switcher argument[1]: '--locale=enUS'


Then after updating, it tries to launch with a locale called 'monthly budget':
#-----------------------------------------------------------
# System started at 2012-09-19 04:05:45.1946
# system: [removed] Mac Pro
#-----------------------------------------------------------
04:05:45.1961 switcher argument[1]: '--locale=Monthly Budget:


Can you send me your system profiler so I can look at your system?

Obtaining your System Information and system.log
Snow Leopard (10.6) and older versions of OS X
    1. Hold the Option Key and choose System Profiler from the Apple Menu
    2. When the System Profiler is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location. Make sure the file format is "System Profiler 4.0 (XML)"

Lion (10.7)
    1. Hold the Option Key and choose System Information from the Apple Menu
    2. When the System Information is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location.

Obtaining your system.log
    1. Using Finder, Navigate to /Applications/Utilities and open Console
    2. Click system.log on the left side bar.
    3. On the menu bar, click File, and select Save a Copy As. Make sure the file is saved to the desktop for easy location.

Submitting your system files
    1. Open a new email message, and attach the items as an attachment.
    2. Send the email to macsupport@blizzard.com with the subject as "Attn: TonyM". Make sure you include the Thread title and URL address. This way it gets routed to me so I can take a personal look.

Please note: This method is only used for sending information after files are requested for additional review. This is not to be used a a form of contact, as this box is monitored only when files are requested. No replies are sent from here.
Monthly Budget??

Oh.... i think i figured it out. I accidentally overwrote launcher.db in /Applications/Starcraft II/ with my 'monthly budget'. Since OS X Lion apps automatically open the last document used when you launch them and it still confuses me! I think i was troubleshooting another problem i was having a few months back and may have opened it then.

I reverted the file back to the original file now it works fine!

Thanks for your help.
Jason
I am having a similar problem and I cannot figure out what it is.. I am also running MacOSX and when I try to open SC2 shortcut on my desktop it says "An internal error occurred, please restart. If problems persist contact costumer support." Can anybody help me??
Can you send me the requested files and I'll see what I can find out?
not to beat a dead horse, but I'm having an identical problem. I can only play the game once before having to uninstall then reinstall it and i get that same message.
Send me the same files as requested before and I'll find out what is happening.
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
The more things change, the more they stay the same.
lol same problem, im sending you my zip file of batlle net

Join the Conversation

Return to Forum