Launcher stuck at "Initializing"

Technical Support
so its tuesday and the new patch was put in to my knowledge, however when i start starcraft 2 it opens the launcher and is stuck at "Initializing..." and i am not givin the option to play or do anything. is this just my problem or is this because of the patch or something else entirely? any help would be greatly appreciated

edit: ive also tried running it as an admin and running the .exe from the folder itself as opposed to the shortcut
Vega, I would try powercycling your network as well as flushing the DNS cache. I would also boot into a Selective Startup, and see if that helps.
Technical Support
'Constant change is here to stay.'
Same problem, tried powercycling, it worked for a couple seconds. And then it the screen went blank, went back to my desktop and the launcher popped up saying initializing again, almost is if it was mocking me.

Unfortunately, I am at a college campus so I can't reset the router. Any other ideas?
Ok so nothing worked and i went for a reinstall. to my dismay however, after the ganme installs and it goes thru the first patch, i get a tony window that says "checking for updates" where a green bar proceeds to fill to about 70% and then it stops entirely. the program is still working because the ...'s are still coming and going but it will not progross any further and thus i cannot patch/play. please help me, i dont know if all of these problems are from the new patch yesterday or what but something is strange
Same problem, load up sc2 and the launcher just says " Initializing ", no loading bar or anything. Can't press play. How do I fix this? =(
same here ...
ok so reinstall helped if that helps anyone taht hasnt done that yet
Same thing here, not only with SC but frequently happens with Diablo 3 and WoW as well. First time it's ever happened with SC.

It's a shame you have to reinstall the game or be a PC power user/programmer just to play Blizzard games. I've had this problem with their launchers in general for over a year now and still haven't found a solution other than trying over and over and over and over again.

Not to mention, patching takes an unbelievable amount of time, even for smaller <10MB patches. Literally every other game, patch, or file I download takes seconds at most, yet this one small update has so far taken longer than it's taken me to write this entire post.
I got a new PC, and on my old one it was working, fine, (Just kinda slow), but now I really want to play but its stuck on initializing
same here, my game was working perfectly fine last night though.

Also, my internet is fine...
I've played like 15 games since the update. After realizing my connection was being jeopardized by a discrete patch dl, I let it finish and played at least 5 more. Now all the sudden I have a freeze when... new patch came up just now...
Same problem here
Same prob on my laptop! Had the very last patch from HOTS. No solution to this?
Elnino, there are several possible solutions to this issue. Please let us know how it goes, and we can work from there.

Rate me!
I also got a new PC and now i am stuck at initializing i tried to re install the game it took two day with all the updates and downloads but it work i played the game next day stuck at initializing again, i have anther computer sitting right next to mine running off the same router it works fine could it be the firewall?
Yes, it could be the firewall, or another security program. I would try these steps, in turn, and see how it goes:

1) Configure your security program.

2) Disable your security program.

3) Uninstall your security program, and reinstall it afterwards.
Rate me!

Join the Conversation

Return to Forum